it-swarm.com.de

Verbindung unterbrochen. Speichern wurde deaktiviert ... (Aktualisieren von Posts/Seiten)

Ich habe für Wordpress seit ein paar Jahren ohne Probleme auf einem alten XP/WAMP-Entwicklungsserver (v1.7.4) entwickelt, habe aber kürzlich den Fehler " Verbindung verloren. Das Speichern wurde deaktiviert, bis Sie wieder verbunden sind ", wenn ich versuche, Wordpress Posts oder Pages zu aktualisieren. Der Großteil dessen, was ich zum Thema aufgeschlagen habe, verweist auf Plugins als Ursache des Problems. Leider stelle ich fest, dass das Problem auch bei einer sauberen Installation von WordPress 3.8.1 in einer neuen Datenbank ohne Plugins weiterhin besteht. Der nächste logische Schuldige ist dann der Server. Ich überprüfe die Protokolle und finde nichts. Während der Migration meines Workflows auf eine neuere Windows 7-Plattform (WAMP v2.2.22) habe ich dort eine neue Installation erstellt, und das Problem ist behoben. Ich habe die php.ini von beiden Servern über eine Differenzierungs-Engine ausgeführt, um die Ursache herauszufinden, aber ich fürchte, es ist mir ein bisschen unverständlich, wo das Problem liegen könnte und wie ich die Ergebnisse des Vergleichs hier weitergeben kann als flache Datei oder CSV. Irgendwelche Gedanken?

5
user48973

Diese Meldung resultiert daraus, dass Ihr Server einen 503-Fehler auslöst und die WordPress Heartbeat-API diesen Fehler abfängt. Unter https://core.trac.wordpress.org/ticket/25660 finden Sie Informationen zum Update, das WordPress zum Speichern von Offline-Änderungen eingeführt hat.

Auf Ihrem Computer sollten Sie überprüfen, ob WAMP tatsächlich ausgeführt wird, wenn Sie diese Meldung erhalten (überprüfen Sie das Statussymbol in der Taskleiste). Sie sollten auch sicherstellen, dass keine anderen Programme versuchen, den von WAMP verwendeten Port zu übernehmen. Es gibt zahlreiche Berichte über Skype und TeamViewer, die die Kontrolle über die Ports 80 und 443 übernehmen, sowie Korrekturen für jeden von ihnen.

Wenn Sie die WAMP-Foren nicht ausgecheckt haben, finden Sie auf dieser Seite eine Beschreibung der Schritte zum Debuggen des 503-Serverfehlers sowie Korrekturen für Skype und TeamViewer: http://forum.wampserver.com/read.php?2, 115474,115576 .

3
Morgan Estes

Versuche Folgendes:

  1. Alle Plugins deaktiviert, Plugins-Ordner vollständig entfernt - Problem bleibt bestehen.
  2. Die .htaccess-Datei wurde entfernt - das Problem besteht weiterhin.
  3. Versucht eine Neuinstallation - Problem bleibt bestehen.
  4. Browser-Cache geleert.
  5. Überprüfte den Server auf automatische Updates - es gab keine.
  6. Die automatische Speicherung wurde zu verschiedenen Zeiten geändert. define( 'AUTOSAVE_INTERVAL', 160 );

Mehr Info

0
jim.duck