it-swarm.com.de

Blog-Posts, deren Titel nicht angezeigt wird

Ich habe die Leseeinstellungen auf Statische Seiten und das Blog auf eine Seite namens Was ist neu eingestellt.

Wenn ich zu dieser Seite "Neuigkeiten" gehe, wird der Inhalt des Beitrags angezeigt, aber der Beitragstitel mit dem Link zur Beitragsseite wird nicht angezeigt. Ich kann nur den Inhalt des Beitrags sehen.

Ich habe alles getan, um den Fehler zu finden, ohne Glück, bitte helfen Sie!

Code für index.php:

<div id="content" class="narrowcolumn" role="main">
    <?php if (have_posts()) : ?>
        <?php while (have_posts()) : the_post(); ?>
            <div <?php post_class(); ?> id="post-<?php the_ID(); ?>">
                <h2><a href="<?php the_permalink() ?>" rel="bookmark" title="<?php printf(__('Permanent Link to %s'), the_title_attribute('echo=0')); ?>"><?php the_title(); ?></a></h2>
                <small><?php the_time(__('F jS, Y')) ?> <!-- by <?php the_author() ?> --></small>
                <div class="entry">
                    <?php the_content(__('Read the rest of this entry &raquo;')); ?>
                </div>
                <p class="postmetadata"><?php the_tags(__('Tags:') . ' ', ', ', '<br />'); ?> <?php printf(__('Posted in %s'), get_the_category_list(' ')); ?> | <?php edit_post_link(__('Edit'), '', ' | '); ?>  <?php comments_popup_link(__('No Comments &#187;'), __('1 Comment &#187;'), __('% Comments &#187;''), '', __('Comments Closed') ); ?></p>
            </div>
        <?php endwhile; ?>

Ich bin mir nicht sicher, ob es relevant ist, aber ich habe das auf der Seitenvorlage auskommentiert.

Code für whats-new.php:

<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    <div class="post" id="post-<?php the_ID(); ?>">
        <h1><?php the_title(); ?></h1>
            <div class="entry">
                <?php the_content(''); ?>
            </div>
        </div>
</div>
<?php endwhile; endif; ?>

Ich hoffe jemand kann helfen! Wenn Sie irgendwelche Ideen haben, werden sie sehr geschätzt. Ich habe versucht, Teile meiner Funktionsdatei zu entfernen, das Blog unter Einstellungen zur Startseite zu machen und so weiter.

Irgendwelche Ideen?

1
talkingD0G

Möglicherweise wurde Ihre Seite in den Optionen auf der Seite als "Neben" und nicht als "Standard" -Post festgelegt.

Das hat das Problem verursacht, das Sie für mich beschrieben haben.

1
Peter Johnssn

Entfernen Sie den <!-- --> in <!--<h1><?php the_title(); ?></h1>-->. Dies sind HTML-Kommentare, damit er nicht angezeigt wird.

1
Horttcore