it-swarm.com.de

Kann ich ein Plugin auf eine bestimmte Version aktualisieren?

Ich teste Plug-in-Upgrades auf einer Staging-Instanz, bevor ich sie auf die Produktion übertrage. Wenn sich dieser Vorgang jedoch verzögert, werde ich möglicherweise aufgefordert, ein Upgrade auf eine neuere, nicht getestete Version für die Produktion durchzuführen.

Wie kann ich ein Zwischenupdate anstelle des neuesten auswählen, wenn ich zum Aktualisieren eines Plugins aufgefordert werde?

11
david.libremone

Mit WP-CLI können Sie dies wie in der offiziellen Dokumentation beschrieben festlegen.

$ wp plugin update <plugin>

Verwenden Sie eines der folgenden Argumente

--minor

Führen Sie Updates nur für kleinere Releases durch (z. B. von 1.3 auf 1.4 anstelle von 2.0).

--patch

Führen Sie Updates nur für Patch-Releases durch (z. B. von 1.3 auf 1.3.3 anstelle von 1.4).

--version=<version>

Wenn gesetzt, wird das Plugin auf die angegebene Version aktualisiert.

21
kero

Sie können auch bestimmte Versionen vom SVN des Plugins herunterladen.

Angenommen, Sie möchten eine bestimmte Version von Yoast.

https://wordpress.org/plugins/wordpress-seo /

https://plugins.svn.wordpress.org/wordpress-seo/tags /

Der Ordner tags listet alle Versionen auf.

2
Liam Stewart