it-swarm.com.de

Upgrade von 3.8.7 auf 3.8.8 - Fehler - Verwenden Sie $ this, wenn Sie sich nicht im Objektkontext befinden

Meine Seite ist komplett ausgefallen. Das Austauschen meiner benutzerdefinierten Vorlage durch eine andere sehr kleine Vorlage ermöglicht den Betrieb des Systems, jedoch ohne die meisten Positionen. Ich glaube, dass der Fehler "Using $ this, wenn nicht im Objektkontext" beweist, dass das Problem mit PHP zusammenhängt. Ich bin auf der Suche nach dem besten Weg, die Site wieder auf Version 3.8.7 zu bringen, bis das Vorlagenproblem behoben werden kann. Die PHP Version auf dem Server hat sich nicht geändert. PHP Version 7.2.5-1 + ubuntu16.04.1 + deb.sury.org + 1. Jeder Rat zum Debuggen dieses Problems wird gebeten.

2
Phil Schaming

Das Zufallsbildmodul hat ein Problem in Joomla 3.8.8. Einzelheiten finden Sie unter:

https://docs.joomla.org/J3.x:Module_random_image_PHP_Error_after_3.8.8

Die Lösung finden Sie hier:

https://github.com/joomla/joomla-cms/pull/20533/files

3
Neil Robertson