it-swarm.com.de

Xampp Warnung: Modul 'openssl' ist bereits in Zeile geladen

Ich habe Xampp unter Windows 7 installiert. Wenn ich versuche, Code auszuführen, erhalte ich die Fehlermeldung

Warnung: Modul 'openssl' ist bereits in Zeile 0 geladen

Dies ist derselbe Code, den ich zuvor auf dem PC ausgeführt habe. Alles, was ich getan habe, ist, Win 7 neu zu installieren und eine saubere Installation von XAMPP

32
Mesogi

Sie scheinen die Linie zu haben

extension=php_openssl.dll

zweimal in Ihrer php.ini-Datei und/oder -Unterdateien.

Sie müssen alle relevanten php.ini-Dateien in Ihrem xampp-Verzeichnis finden und eine der Modulanweisungen entfernen oder auskommentieren:

;extension=php_openssl.dll

Nach einem Neustart des Servers sollte dies behoben sein.

74
radonthetyrant
  1. Откройте xampp -> PHP -> php.ini

  2. Откройте файл php.ini в любом текстовом редакторе.

  3. НажмитеCTRL+Fи поиск openssl

  4. Weitere Informationen zu extension=php_openssl.dll, finden Sie unter: ;extension=php_openssl.dll

Bitte beachten Sie, dass Sie die folgenden Anweisungen beachten müssen:

20
mtmfahath

installieren Sie xampp und geben Sie der erforderlichen Leiste in der Composer-Installation einen neuen Speicherort an.

0

Ich hatte das gleiche Problem und es gab in meinem Fall nicht mehrere extension=php_openssl.dll. Der Grund war, dass ich aus einigen Gründen zwei Kopien von Apache hatte, aber nur eines davon verwendet habe.

Ich habe die Kopie gelöscht und die Umgebungsvariable Path und OPENSSL_CONF so geändert, dass sie auf den richtigen Webserver verweist.

Nach dem Neustart des Webservers hat es funktioniert! Stellen Sie sicher, dass Sie alle Terminals und CMDs neu starten, ansonsten werden die alten Umgebungsvariablen verwendet und der Fehler bleibt bestehen.

0
Black