it-swarm.com.de

Wie kann man php von 7.1.1 auf 5.6 in xampp 7.1.1 herunterstufen?

Ich möchte PHP-Version von 7.1.1 auf 5.6 in Xampp 7.1.1 herunterstufen. Aber ich kann keine Option finden .  PHP info from xampp

11
Shiblee Sadik

Ich denke, der sicherste Downgrade-Pfad von PHP7 zu PHP5 in Xampp ist:

  1. Laden Sie eine selbstverpackte Version von Xampp mit PHP5 von hier herunter (heute ist dies xampp-win32-5.6.37-0-VC11.Zip).

  2. Benennen Sie den Ordner php in Xampp in php7 um.

  3. Kopieren Sie nun den php-Ordner von xampp-win32-5.6.37-0-VC11.Zip in Ihren Xampp-Installationsordner.

  4. Erstellen Sie eine Sicherung aus der \xampp\Apache\conf\extra\httpd-xampp.conf-Datei.

  5. Ersetzen Sie auch diese Datei aus xampp-win32-5.6.37-0-VC11.Zip.

  6. Auf diese Weise haben die Konfigurationsdateien (einschließlich php.ini) Einstellungen vom Xampp-Team.

Benachrichtigen Sie mich, wenn ich etwas vermisse.

5
Lanti

Es gibt keine Option zum Downgrade von XAMPP. XAMPP ist mit einer bestimmten PHP -Version fest codiert, um sicherzustellen, dass alle Module kompatibel sind und ordnungsgemäß funktionieren. Wenn für Ihr Projekt jedoch PHP 5.6 erforderlich ist, können Sie einfach eine ältere Version von XAMPP installieren, in der PHP 5.6 enthalten ist.

Quelle: Wie man php von 5.5 auf 5.3 herabstufen kann

3
roundAbout

Löschen Sie einfach dieses xampp und laden Sie die Version 5.6 herunter.

2

XAMPP ist ein integriertes Paket, und Sie können eine ihrer Komponenten wie php nicht herunterstufen oder ändern. (Es gibt einige Lösungen, die Sie verwenden können, aber es ist unwahrscheinlich, dass alles gut funktioniert.)

Sie können das Paket von diesen Links herunterladen:

Sie sollten lieber das alte Paket sourceforge.net herunterladen.

2
A mohseni

Ändern Sie den .htaccess-Code, um zu PHP 5.6 zu wechseln:

AddHandler application/x-httpd-php56 .php
1
Adi

Wenn Sie die PHP-Version downgraden möchten, bearbeiten Sie einfach die .htaccess-Datei . Wenn Sie eine PHP-Version auf 5.6 herunterstufen möchten, fügen Sie diese einfach in die .htaccess-Datei ein

<FilesMatch "\.(php4|php5|php7|php3|php2|php|phtml)$">  
etHandler application/x-lsphp56
</FilesMatch>
0
Md Zahid Shams

Sie müssen keine weitere Version von Xampp installieren. Ich habe es geschafft, PHP 5.6 auf meiner Xampp PHP 7-Version zu verwenden. Um es funktionieren zu lassen, müssen Sie Folgendes tun:

  1. Raname (Sicherung) <XAMPP_DIR>\php bis <XAMPP_DIR>\php~7
  2. Kopieren (Sichern) <XAMPP_DIR>\Apache\conf\extra\httpd-xampp.conf in <XAMPP_DIR>\Apache\conf\extra\httpd-xampp~7.conf
  3. Laden Sie PHP5 herunter und entpacken Sie es in <XAMPP_DIR>\php
  4. Bearbeiten Sie <XAMPP_DIR>\Apache\conf\extra\httpd-xampp.conf und ändern Sie alle php5-Vorkommen in php7. Sie müssen php7Apache2_4.dll in php5Apache2_4.dll, php7ts.dll in php5ts.dll und php7_module in php5_module ändern. 
  5. Stellen Sie sicher, dass alle Ihre Pfade korrekt sind, wie extension_dir in php.ini.

Starten Sie Apache und Voila neu.

0
Erroid

Wenn Sie php von 7.1.1 auf 5.6 in xampp downgraden möchten, folgen Sie den Schritten (für Windows): -

  1. Gehen Sie zu https://sourceforge.net/projects/xampp/files/XAMPP%20Windows/5.6.36/
  2. Laden Sie die Datei herunter und entpacken Sie sie. Xampp-win32-5.6.36-0-VC11.Zip siehe Bild Bild 1
  3. Löschen Sie den Ordner php und den Ordner Apache in C:\xampp.

  4. Kopieren Sie den Ordner php und Apache aus der extrahierten Datei und fügen Sie ihn in C:\xampp ein.

  5. Fügen Sie "C:" vor \ xampp\in Zeile 709, 734, 816, 937, 14281462, 2025, 2034 bis php ini -Datei im php-Ordner vorhanden.

  6. Starten Sie Ihren Apache und MySQL und überprüfen Sie die PHP-Version. Es zeigt php 5.6.36

0
Mas