it-swarm.com.de

Wie installiert man php-curl in Ubuntu 16.04

Upgrade auf Ubuntu 16.04 und Problem nach Installation von PHP5.

Installierte PHP-5 mit folgendem:

Sudo add-apt-repository ppa:ondrej/php
Sudo apt-get update
Sudo apt-get upgrade
Sudo apt-get install php5.5   # for PHP 5.5

Der Versuch, PHP-Curl zu installieren, funktioniert aber nicht.

Sudo apt-get install php5-curl

Fehler: E: Paket php5-curl konnte nicht gefunden werden

47
Govind Samrow

In Ubuntu 16.04 ist die Standardversion PHP 7.0. Wenn Sie eine andere Version verwenden möchten, müssen Sie das Paket PHP gemäß PHP Version installieren:

  • PHP 7.2: Sudo apt-get install php7.2-curl 
  • PHP 7.1: Sudo apt-get install php7.1-curl 
  • PHP 7.0: Sudo apt-get install php7.0-curl 
  • PHP 5.6: Sudo apt-get install php5.6-curl
  • PHP 5.5: Sudo apt-get install php5.5-curl
151
Govind Samrow

Das hat bei mir funktioniert.

Sudo apt-get install php-curl
23
Aaganja

Das funktioniert für mich:

Sudo apt-get install php5.6-curl
20
Nehal J Wani

CURL 7.49.0 auf Ubuntu 16.04 und Derivaten installieren

wget http://curl.haxx.se/download/curl-7.49.0.tar.gz
tar -xvf curl-7.49.0.tar.gz
cd curl-7.49.0/
./configure
make
Sudo make install
4
Khalid Bin Huda

Tun:

# apt-get update

Und dann:

# apt-get install php5-curl

Für Benutzer von Ubuntu 18.04 oder PHP 7.2 haben Sie folgende Möglichkeiten:

apt-get install php7.2-curl

Sie können Ihre PHP Version überprüfen, indem Sie php -v ausführen, um Ihre PHP Version zu überprüfen und die richtige Curl-Version zu erhalten.

1
Yaser AlAzem
Sudo apt-get install php5.6-curl

und starten Sie den Webbrowser neu. 

Sie können die Module überprüfen, indem Sie php -m | grep curl ausführen.

0
Linuxian