it-swarm.com.de

Schwerwiegender Fehler: Klasse 'Illuminate\Foundation\Application' wurde nicht gefunden

Ich erhalte eine Fehlermeldung, wenn ich meine Site öffne, die mit Laravel 5 erstellt wurde

Schwerwiegender Fehler: Die Klasse 'Illuminate\Foundation\Application' wurde nicht in C:\cms\bootstrap\app.php in Zeile 14 gefunden

Ich habe versucht, Herstellerordner und composer.lock-Datei zu entfernen und Composer zu installieren. Es funktioniert nicht. Ich habe versucht, PHP Handwerkeroptimierung auszuführen, aber es wird ein Fehler angezeigt

Schwerwiegender Fehler: Class'Illuminate\Foundation\Application 'wurde nicht gefunden

Gibt es eine Möglichkeit, dieses Problem zu lösen?

Bearbeitet: .__ Dieses Problem trat auf, sobald ich den php artisan make:model Page-Befehl verwendete, mit dem das Modell erstellt wurde. Der obige Fehler wird jedoch angezeigt, wenn ich auf die Site ___ gehe. Auch wenn Sie den Local Development Server von Larvel verwenden, tritt ein solches Problem nur dann auf, wenn Ich benutze Wamp Server

27
xenish

In meiner Situation hatte ich nicht die vollständigen Abhängigkeiten der Hersteller (Composer-Datei wurde während der ursprünglichen Installation durcheinander gebracht) - daher führte das Ausführen von Handwerkerbefehlen zu einem Fehler.

Ich konnte das Flag --no-scripts verwenden, um zu verhindern, dass ein Handwerker ausgeführt wird, bevor er eingefügt wurde. Sobald meine Abhängigkeiten vorhanden waren, funktionierte alles wie erwartet.

composer update --no-scripts
47
Daniel Mitchell

Nur für den Fall, dass ich diesen Fehler in 2 Wochen noch einmal stolpere ... Mein Fall: Ein vorhandenes Projekt über git auschecken und alle Abhängigkeiten über den Composer abrufen. Auf den gleichen Fehler im Titel dieses Beitrags zurückgeführt.

Lösung:

composer dump-autoload
composer install --no-scripts

stellen Sie sicher, dass jetzt alles wie erwartet funktioniert (keine Fehler!)

composer update
21
mwallisch

Etwas ist eindeutig in Ihrem Laravel-Setup beschädigt und es ist sehr schwer, ohne weitere Informationen über Ihre Umgebung nachzuverfolgen. Normalerweise helfen Ihnen diese beiden Befehle, solche Probleme zu lösen

php artisan clear-compiled
composer dump-autoload

Wenn nichts anderes hilft, empfehle ich Ihnen, die neue Laravel 5-App zu installieren und Ihre Anwendungslogik zu kopieren. Es sollte ungefähr 15 Minuten dauern.

4
Margus Pala

Für die neueste Laravel-Version überprüfen Sie auch Ihre Version, da ich auch diese Fehlermeldung hatte. Nach dem Update der neuesten PHP-Version wurde diese Fehlermeldung jedoch entfernt.

0
Ajay Malhotra

Ich habe dieses Problem gerade behoben (Unterschiedlicher Fall mit gleichem Fehler),
Die Antwort, die ich oben ausprobiert habe, funktioniert möglicherweise nicht, weil Mein Fall anders war, aber den gleichen Fehler hervorbrachte.
Ich glaube, meine Vendor-Bibliotheken waren durcheinander,
Ich bekomme diese Fehlermeldung durch:
1. Ziehen Sie aus Remote-Git, Master-Zweig ist Codeigniter, dann mache ich Composer-Update auf Master-Zweig. Ich wollte an Laravel-Zweig arbeiten. 

Schwerwiegender Fehler: Die Klasse 'Illuminate\Foundation\Application' wurde nicht in .__ gefunden. C:\cms\bootstrap\app.php in Zeile 14

Lösung: Ich lösche das Projekt auf local und mache erneut einen Klon. Danach checke ich den Zweig meiner Laravel-Datei ab und aktualisiere den Composer.

0
Calvin

1. Öffnen Sie zuerst den Befehl Prompt (cmd ==> window + r) und gehen Sie zu der Stelle, an der sich Laravel befindet
Eingerichtet.

2.Try ==> Komponist benötigt Laravel/Laravel

0
ankit kumawat