it-swarm.com.de

Php7.0-imap kann nicht installiert werden

Ich benutze Ubuntu 16.04.1, habe PHP7 im August installiert, aber heute habe ich versucht, die IMAP-Erweiterung zu installieren, und es lässt mich nicht.

[email protected]:/etc# apt-get install php7.0-imap
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php7.0-imap : Depends: php7.0-common (= 7.0.8-0ubuntu0.16.04.3) but 7.0.9-1+deb.sury.org~trusty+1 is to be installed
E: Unable to correct problems, you have held broken packages.

Dies sind die Ergebnisse der Apt-Cache-Suche php7- *:

libapache2-mod-php7.0 - server-side, HTML-embedded scripting language (Apache 2 module)
php-all-dev - package depending on all supported PHP development packages
php7.0 - server-side, HTML-embedded scripting language (metapackage)
php7.0-cgi - server-side, HTML-embedded scripting language (CGI binary)
php7.0-cli - command-line interpreter for the PHP scripting language
php7.0-common - documentation, examples and common module for PHP
php7.0-curl - CURL module for PHP
php7.0-dev - Files for PHP7.0 module development
php7.0-Gd - Gd module for PHP
php7.0-gmp - GMP module for PHP
php7.0-json - JSON module for PHP
php7.0-ldap - LDAP module for PHP
php7.0-mysql - MySQL module for PHP
php7.0-odbc - ODBC module for PHP
php7.0-opcache - Zend OpCache module for PHP
php7.0-pgsql - PostgreSQL module for PHP
php7.0-pspell - pspell module for PHP
php7.0-readline - readline module for PHP
php7.0-recode - recode module for PHP
php7.0-snmp - SNMP module for PHP
php7.0-sqlite3 - SQLite3 module for PHP
php7.0-tidy - tidy module for PHP
php7.0-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
php7.0-xmlrpc - XMLRPC-EPI module for PHP
libphp7.0-embed - HTML-embedded scripting language (Embedded SAPI library)
php7.0-bcmath - Bcmath module for PHP
php7.0-bz2 - bzip2 module for PHP
php7.0-enchant - Enchant module for PHP
php7.0-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)
php7.0-imap - IMAP module for PHP
php7.0-interbase - Interbase module for PHP
php7.0-intl - Internationalisation module for PHP
php7.0-mbstring - MBSTRING module for PHP
php7.0-mcrypt - libmcrypt module for PHP
php7.0-phpdbg - server-side, HTML-embedded scripting language (PHPDBG binary)
php7.0-soap - SOAP module for PHP
php7.0-sybase - Sybase module for PHP
php7.0-xsl - XSL module for PHP (dummy)
php7.0-Zip - Zip module for PHP
php7.0-dba - DBA module for PHP

Hilfe?

2
Dino

Sie haben anscheinend ein PPA installiert, das eine neuere Version von PHP (7.0.9) als die Hauptrepositorys (7.0.8) bietet. Aber diese PPA scheint keine 7.0.9-Version von php7.0-imap anzubieten. Also versucht apt, die neueste Version von php7.0-imap zu installieren, das Paket aus den Haupt-Repos. Das hängt vom 7.0.8-0ubuntu0.16.04.3 -Paket der Haupt-Repos ab, aber die PPAs 7.0.9-1+deb.sury.org~trusty+1 sind nicht kompatibel.

Sie können entweder die PPA deaktivieren, wenn Sie PHP 7.0.9 anstelle von 7.0.8 nicht wirklich benötigen, oder Sie können nach der PPA mit 7.0.9 suchen, die auch php7.0-imap enthält .

1

Möglicherweise haben Sie php7.0-common in einer alten Version installiert.

Überprüfen Sie mit: Sudo dpkg --get-selections | grep php

0
Richard Bailón