it-swarm.com.de

php5-openssl Paket für Ubuntu 16.04 LTS?

dev_appserver.py unterstützt kein PHP7. Ich habe php5.6 von ppa: ondrej/php installiert, aber ich kann kein openssl ladbares Modul finden. Die Pakete php5-openssl und php5.6-openssl scheinen nicht zu existieren.

Wo finde ich ein kompatibles PHP openssl-Modul?

4
Brian K Haney

Sie brauchen kein openssl-Modul, es ist eingebaut:

$ php5.6 -r 'phpinfo();' | grep -i openssl
openssl
OpenSSL support => enabled
OpenSSL Library Version => OpenSSL 1.0.2h  3 May 2016
OpenSSL Header Version => OpenSSL 1.0.2h  3 May 2016
Openssl default config => /usr/lib/ssl/openssl.cnf
openssl.cafile => no value => no value
openssl.capath => no value => no value
Native OpenSSL support => enabled
2
oerdnj

Versuchen:

php -i | grep -i openssl

um zu sehen, ob OpenSSL bereits installiert wurde, scheint die OpenSSL-Erweiterung standardmäßig installiert zu sein ...

0
simhumileco