it-swarm.com.de

Paket Laravel-Laravel mit stabiler Stabilität konnte nicht gefunden werden

Beim Versuch, ein Projekt auf Ubuntu 16.04 mit PHP 7 zu erstellen, erhalte ich die folgende Fehlermeldung:

Paket Laravel-Laravel mit stabiler Stabilität konnte nicht gefunden werden

Was ist die Lösung dafür?

6
Beauty akter

sie haben einen Tippfehler, verwenden Sie diesen

  composer create-project --prefer-dist laravel/laravel test
16
Achraf Khouadja

Es ist nicht laravel-laravel, es ist laravel/laravel.

Sie verwenden Vendor/Paketname mit Composer.

# composer info -a laravel/laravel
name     : laravel/laravel
descrip. : The Laravel Framework.
keywords : framework, laravel
versions : dev-master, v5.2.31, v5.2.29, v5.2.27, v5.2.24, v5.2.23, v5.2.15, v5.2.0, 5.1.x-dev, v5.1.33, v5.1.11, v5.1.4, v5.1.3, v5.1.1, v5.1.0, 5.0.x-dev, v5.0.22, v5.0.16, v5.0.1, v5.0.0, v4.2.11, v4.2.0, v4.1.27, v4.1.18, v4.1.0, v4.0.9, v4.0.8, v4.0.7, v4.0.6, v4.0.5, v4.0.4, v4.0.0, v4.0.0-BETA4, v4.0.0-BETA3, dev-develop
type     : project
license  : MIT License (MIT) (OSI approved) https://spdx.org/licenses/MIT.html#licenseText
source   : [git] https://github.com/laravel/laravel.git 47d7e2d490c969a91d8aaad735bf36b5dba53bfa
dist     : [Zip] https://api.github.com/repos/laravel/laravel/zipball/47d7e2d490c969a91d8aaad735bf36b5dba53bfa 47d7e2d490c969a91d8aaad735bf36b5dba53bfa
names    : laravel/laravel

autoload
classmap
database
psr-4
App\ => app/

requires
php >=5.5.9
laravel/framework 5.2.*

requires (dev)
phpunit/phpunit ~4.0
fzaninotto/faker ~1.4
mockery/mockery 0.9.*
symfony/css-selector 2.8.*|3.0.*
symfony/dom-crawler 2.8.*|3.0.*
6
Devon

Ich habe den Komponisten benutzt, um Lavarel/Lumen zu benötigen, und ich habe das gleiche Problem getroffen, weil ich einen falschen Befehlszauber habe: falscher Befehl

composer global require "laravel/Lumen-installer"

der richtige Befehl ist der: korrekte Befehl

composer global require "lavarel/Lumen-installer"

2
i.yuanx

Ist auf diese Weise:

composer create-project --prefer-dist laravel/laravel [proyect_name]
1
Cornielle

Versuche dies:

composer  create-project laravel/laravel yourNameProject  "5.5.*"
0
Tomas Beltran

Die Version von PHP ist alt, um die Version von PHP auf 7.0 zu erhöhen, versuchen Sie, die neue Version von XAMPP zu installieren. 

0
Baseer Ebadi

1- Erstellen Sie den Ordner larvel in xammp/htdocs

2 Starten Sie das Eingabeaufforderungsfenster (CMD) oder das Terminal über den neuen Pfad

3-Typ diese Befehlszeile/Terminal:

 composer create-project laravel/laravel  --prefer-dist firstapp

4- Geben Sie CMD/Terminal-CD ein (Name Ihres Projekts [firstap])

5-run in localhost: 8000 durch Eingabe von CMD/Terminal 

 php artisan serve

6 Halten Sie 60 Sekunden, bis die Ordner auf Ihrem Computer heruntergeladen werden

0
Abu Bakr