it-swarm.com.de

Nach dem Ubuntu 18.04 Upgrade kann php7.2-curl nicht mehr installiert werden

Heute von 16.04 auf 18.04 aktualisiert mit do-release-upgrade -d

Während des Upgrades wurde ich informiert, dass einige Pakete entfernt werden würden, darunter:

Entfernen Sie: libperl5.22 lxc-common Perl-modules-5.22 php-imagick
php7.1-curl php7.2-curl python3-certbot-nginx

Ich könnte imagick und certbot ohne Probleme neu installieren, aber wenn ich versuche, php7.2-curl zu installieren, erhalte ich die Meldung:

# apt install php7.2-curl -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php7.2-curl : Depends: php7.2-common (= 7.2.3-1ubuntu1) but 7.2.4-1+ubuntu16.04.1+deb.sury.org+1 is to be installed
E: Unable to correct problems, you have held broken packages.

Wie kann ich die Situation korrigieren?

24
Arni J

Dies kann Ihnen Folgendes ersparen:

Sudo add-apt-repository ppa:ondrej/php
Sudo apt update
Sudo apt install php7.2-fpm php7.2-Gd php7.2-curl php7.2-mysql php7.2-dev php7.2-cli php7.2-common php7.2-mbstring php7.2-intl php7.2-Zip php7.2-bcmath

Dann Sudo service Apache2 restart

52
Anson Wong

Sie müssen kein neues Repo hinzufügen. Wenn Sie dies tun, wird die Version 7.2 installiert. Denken Sie daran, PHP und Apache nach dem Neustart. Achte auch darauf (das hast du aber wahrscheinlich schon gemacht), um den neuen Mod zu aktivieren, nachdem:

Sudo apt install php-curl
Sudo a2enmod php7.2

Sie werden wahrscheinlich auch bemerken, dass am Ende der Installation von php-curl (installiert php-curl und php7.2-curl) Folgendes (Beachten Sie, dass ich ein FPM-Setup habe, das möglicherweise anders aussieht, wenn Sie kein FPM verwenden):

NOTICE: Not enabling PHP 7.2 FPM by default.
NOTICE: To enable PHP 7.2 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php7.2-fpm
NOTICE: You are seeing this message because you have Apache2 package installed.

Also mach was es sagt:

Sudo a2enmod proxy_fcgi setenvif
Sudo a2enconf php7.2-fpm
Sudo systemctl restart Apache2.service
1
J-a-n-u-s

Die Installation von libcurl4 hat bei mir mit funktioniert

apt install libcurl4

Dann installiert php7.2-curl, Apache2 ohne ein Problem neu gestartet.

0
MickC