it-swarm.com.de

Laravel Installer kann nicht über Composer installiert werden

Ich versuche, das laravel-Installationsprogramm mit dem Composer auf meinem Ubuntu-PC zu installieren, aber ich erhalte diesen Fehler während der Installation. `Ihre Anforderungen konnten nicht in ein installierbares Paket von Paketen gelöst werden.

  Problem 1
    - laravel/installer v1.4.1 requires ext-Zip * -> the requested PHP extension Zip is missing from your system.
    - laravel/installer v1.4.0 requires ext-Zip * -> the requested PHP extension Zip is missing from your system.
    - Installation request for laravel/installer ^1.4 -> satisfiable by laravel/installer[v1.4.0, v1.4.1].

  To enable extensions, verify that they are enabled in those .ini files:
    - /etc/php/7.0/cli/php.ini
    - /etc/php/7.0/cli/conf.d/10-opcache.ini
    - /etc/php/7.0/cli/conf.d/10-pdo.ini
    - /etc/php/7.0/cli/conf.d/20-calendar.ini
    - /etc/php/7.0/cli/conf.d/20-ctype.ini
    - /etc/php/7.0/cli/conf.d/20-exif.ini
    - /etc/php/7.0/cli/conf.d/20-fileinfo.ini
    - /etc/php/7.0/cli/conf.d/20-ftp.ini
    - /etc/php/7.0/cli/conf.d/20-gettext.ini
    - /etc/php/7.0/cli/conf.d/20-iconv.ini
    - /etc/php/7.0/cli/conf.d/20-json.ini
    - /etc/php/7.0/cli/conf.d/20-phar.ini
    - /etc/php/7.0/cli/conf.d/20-posix.ini
    - /etc/php/7.0/cli/conf.d/20-readline.ini
    - /etc/php/7.0/cli/conf.d/20-shmop.ini
    - /etc/php/7.0/cli/conf.d/20-sockets.ini
    - /etc/php/7.0/cli/conf.d/20-sysvmsg.ini
    - /etc/php/7.0/cli/conf.d/20-sysvsem.ini
    - /etc/php/7.0/cli/conf.d/20-sysvshm.ini
    - /etc/php/7.0/cli/conf.d/20-tokenizer.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.
`

Der Fehler erscheint dann, wenn ich diesen Kommentar verwende: 

composer global require "laravel/installer"
51
Andreas Sauer

Es besagt, dass es eine Zip-Erweiterung benötigt

laravel/installer v1.4.0 erfordert ext-Zip ........

Installieren Sie die Version der installierten PHP-Version:

# For php v7.0
Sudo apt-get install php7.0-Zip

# For php v7.1
Sudo apt-get install php7.1-Zip

# For php v7.2
Sudo apt-get install php7.2-Zip
147
Alex

Für PHP7.1 installieren Sie dies

Sudo apt-get install php7.1-Zip
13

Auf Centos 7 habe ich verwendet: 

yum install php-pecl-Zip

weil keine andere lösung für mich funktionierte.

10
Evan

Für Ubuntu 16.04 habe ich diesen Befehl für PHP7.2 verwendet und es hat für mich funktioniert.

Sudo apt-get install php7.2-Zip
3
Amit Khanna

Centos 7 mit PHP7.2:

Sudo yum --enablerepo=remi-php72 install php-pecl-Zip
2
Amirul

Für PHP 7.2 in Ubuntu 18.04 LTS

Sudo apt-get install php7.2-Zip

Klappt wunderbar

1
Ian Samz
V=`php -v | sed -e '/^PHP/!d' -e 's/.* \([0-9]\+\.[0-9]\+\).*$/\1/'` \
Sudo apt-get install php$V-Zip
1
borodatych

Für Mac mit Macports 

# port install php71-Zip
0
Toby

Sudo apt-get installiert PHP-Zip

Diese Lösung hat bei mir funktioniert.

0
Elias Missaoui

Ich verwende WSL mit Ubuntu 16.04 LTS Version mit PHP 7.3 und Laravel 5.7

Sudo apt-get install php7.3-Zip

Arbeite für mich

0
Fil

Zip-Erweiterung fehlt , Sie können diesen Fehler vermeiden, indem Sie einfach den folgenden Befehl ausführen. Standardmäßig wird die Version verwendet

Sudo apt-get install php-Zip

Falls Sie eine bestimmte Version benötigen, müssen Sie eine bestimmte Version Ihres PHP angeben. Angenommen, ich muss X version von php-zip installieren, dann lautet der Befehl.

Sudo apt-get install phpX-Zip  

Ersetzen Sie X durch Ihre gewünschte Version. In meinem Fall ist es X = 7.3.

0
Ankur Tiwari

um Ihre PHP-Version zu kennen

php -v 

für ph 7.3.0

Sudo apt-get install php7.3-Zip
0
mohamed anwer