it-swarm.com.de

Joomla PHP stimmt nicht mit Host PHP überein

Ich bin brandneu in der Webentwicklung und habe Joomla auf meiner Website installiert. Aus irgendeinem Grund kann ich kaum etwas tun, da meine PHP Version laut Joomla nur 5.3 ist.

Mit meinem cpanel habe ich jedoch PHP zu 5.5 geändert.

Wie bringe ich Joomla dazu, die PHP Version zu aktualisieren?

Zusätzliche Informationen: So sieht es aus, ich verstehe nicht, warum Joomla eine andere PHP-Version hat. Unten ist auch die Fehlermeldung, die ich wann sehe Ich versuche ein Vorlagenpaket zu installieren.

enter image description here

5
Sean

Wie andere erwähnen, installiert oder aktualisiert Joomla PHP nicht, sondern meldet lediglich die Version von PHP verfügbar.

Es ist möglich, dass Ihre .htaccess - Datei Anweisungen zum Festlegen der PHP) - Version enthält. Dies ist ziemlich häufig, aber der genaue Code hängt von Ihrem Hosting-Unternehmen ab, sieht aber normalerweise so aus :

AddHandler application/x-httpd-php53 .php .php5 .php4 .php3

Suchen Sie nach dieser Zeile in Ihrer .htaccess - Datei und kommentieren Sie sie aus (fügen Sie # Vor der Zeile hinzu), wenn Sie sie finden. Beachten Sie, dass sich in Ihrem Konto in verschiedenen Ordnern mehrere Instanzen von .htaccess Befinden können.


Sie können auch Ihre PHP) - Versionen überprüfen, indem Sie eine neue .php - Datei erstellen (nennen Sie sie wie Sie möchten) und den folgenden Code in Informationen über Ihre Version anzeigen PHP Einstellungen :

<?php
    phpinfo();
?>

Speichern Sie die Datei und rufen Sie sie in Ihrem Browser auf (z. B. http: //example.com/myphpinfo.php ). Versuchen Sie, die Datei in andere Ordner zu verschieben, und prüfen Sie, ob sich die PHP Version ändert.

Stellen Sie aus Sicherheitsgründen sicher, dass Sie die Datei entfernen, wenn Sie mit dem Testen fertig sind.

3
johanpw

Abhängig von der Art des Hostings und des Hosting-Anbieters ist es möglich, die PHP-Version für Ihr Konto über .htaccess anzupassen. Ich vermute also, dass Ihre htaccess-Datei solche Anweisungen enthalten kann.

Suchen Sie in Ihrer .htaccess-Datei nach Einträgen wie:

AddHandler application/x-httpd-php53 .php

oder so ähnlich, wenn du mit GoDaddy zusammen bist:

AddHandler x-httpd-php5-3 

Entfernen oder kommentieren Sie diese Zeilen mit '# 'vor ihnen wie:

#AddHandler application/x-httpd-php53 .php

Außerdem können Sie mit demselben Befehl versuchen, die gewünschte PHP-Version so einzustellen:

AddHandler application/x-httpd-php55 .php

sie könnten zu PHP 5.5 wechseln.

Auf jeden Fall würde ich Ihnen empfehlen, sich an Ihren Hosting-Anbieter zu wenden, wenn Sie das Problem nicht lösen können.

1
FFrewin