it-swarm.com.de

Installation von Apache 2.4 und PHP 5.5 auf Ubuntu 12.04

Ich versuche, eine Testumgebung mit Apache 2.4 und PHP 5.5 auf einer VM mit Ubuntu 12.04 zu setzen 

apt-add-repository ppa:ptn107/Apache
apt-add-repository ppa:ondrej/php5

Dann installieren Sie Apache 2.4

apt-get install Apache2-mpm-worker

apache-Version überprüfen:

# Apache2 -v
Server version: Apache/2.4.6 (Ubuntu)
Server built:   Sep 23 2013 07:23:34

PHP installieren 5.5

apt-get install php5-common php5-mysqlnd php5-xmlrpc php5-curl php5-Gd php5-cli php5-fpm php-pear php5-dev php5-imap php5-mcrypt

PHP-Version überprüfen

php -v
PHP 5.5.8-3+sury.org~precise+1 (cli) (built: Jan 24 2014 10:15:11) 
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2013 Zend Technologies
     with Zend OPcache v7.0.3-dev, Copyright (c) 1999-2013, by Zend Technologies

Also scheint alles in Ordnung zu sein. Ich brauche mod_fastcgi, kann aber nicht installiert werden:

apt-get install libapache2-mod-fastcgi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you haverequested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
libapache2-mod-fastcgi : Depends: Apache2.2-common (>= 2.2.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Wenn also mod_fastcgi nicht aktiviert werden kann, wie kann ich PHP-Dateien mit PHP-Fpm ausführen? Fehlt mir etwas?

14
poxtron

Sie können den fastcgi-mod und den Apache2 von hier aus installieren, um sicherzustellen, dass er auf meiner Seite funktioniert. https://launchpad.net/~ondrej/+archive/Apache2?field.series_filter=precise

10
webdev

zusätzlich zu suci und wedevs antwort oben, wenn sie einen fehler sehen wie: 

dpkg: error processing /var/cache/apt/archives/Apache2-   bin_2.4.16-4+deb.sury.org~precise+4_AMD64.deb (--unpack):
trying to overwrite '/usr/share/man/man8/Apache2.8.gz', which is also in package Apache2.2-common 2.2.22-1ubuntu1.10

weil Sie etwas Dummes getan haben (wie ich es zum Beispiel mit dem Versuch getan habe, php5 über php2.3 zu installieren, das vom Ubuntu-Image bereitgestellt wird, mit dem ich arbeite), können Sie die folgenden Befehle ausführen:

Sudo dpkg -i --force-overwrite /var/cache/apt/archives/Apache2-bin_2.4.16-3+deb.sury.org~precise+1_AMD64.deb
Sudo dpkg -i --force-overwrite /var/cache/apt/archives/Apache2-data_2.4.16-3+deb.sury.org~precise+1_all.deb
Sudo dpkg -i --force-overwrite /var/cache/apt/archives/Apache2_2.4.16-3+deb.sury.org~precise+1_AMD64.deb

wie hier beschrieben: https://askubuntu.com/questions/666720/ubuntu-apt-get-upgrade-error-on-ubuntu-12-04 von user3703155

ich bin der Meinung, dass der Paketmanager angewiesen ist, die defekten Abhängigkeiten in Bezug auf die Apache2-Installation zu überwinden. 

Anschließend läuft 

apt-get install -f 

gefolgt von 

apt-get dist-upgrade

und danach war alles glücklich.

php -version
PHP 5.5.30-1+deb.sury.org~precise+1 (cli) (built: Oct  4 2015 16:14:34) 
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
with XCache v3.2.0, Copyright (c) 2005-2014, by mOo
with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies
with XCache Optimizer v3.2.0, Copyright (c) 2005-2014, by mOo
with XCache Cacher v3.2.0, Copyright (c) 2005-2014, by mOo
with XCache Coverager v3.2.0, Copyright (c) 2005-2014, by mOo
1
Decoded