it-swarm.com.de

Downgrade von PHP 7.1 auf PHP 7.0

Ich habe einen Ubuntu 16.04 Server mit Nginx + PHP7.1.2. Ich habe ein PHP-Skript, das von einem Cronjob ausgeführt wird. Es enthält einige Kompatibilitätsprobleme (in PHP 7.0 funktioniert es einwandfrei und andere Leute hatten das gleiche Problem) müssen die Version von PHP auf 7.0.14 downgraden (ich denke, dass vielleicht die CLI-Version?). Wie kann ich das machen?

3

sie können den php7.1-Dienst deaktivieren

Sudo a2dismod php7.1

und aktivieren Sie Service-PHP von welcher Version Sie wollen

Sudo a2enmod php5.6

starten Sie dann Ihren Apache neu

Sudo-Dienst Apache2 neu starten

Dadurch wird PHP 7.1 nicht deinstalliert, Sie können jedoch fehlerfrei mit einer herabgestuften Version arbeiten

1
Divyesh pal