it-swarm.com.de

Das Symbol für WAMP Server V 2.5 ist orange, reagiert nicht und es wird kein Menü angezeigt

Ich habe Windows 7 32 Bit und wollte an Wordpress arbeiten, um meine eigene Seite zu hosten. Dafür bekam ich den virtuellen Server WAMP Server V 2.5. Nach der Installation war das Symbol in der Taskleiste orange und nach dem Rechts- und Linksklicken war kein Menü vorhanden . Ich habe viele Foren gelesen, IIS deaktiviert und neu gestartet und nichts. Ebenfalls deinstalliert, gelöschtes Verzeichnis auf c :, erneut installiert, aber dasselbe Ergebnis, kein Menü, orangefarbenes Symbol. Ich bin kein Tech-Experte, also "passen" Sie Ihre Antworten an. Ich habe keine Ahnung, wie man Protokolle prüft usw. Pls lass es mich wissen .

Ich habe vergessen zu erwähnen, dass der Mauszeiger über das Symbol zeigt, dass 1 von 2 Diensten läuft, auf denen der Server offline ausgeführt wird. Ich tippte localhost und ein IIS - Bild wurde angezeigt. Nach dem Deaktivieren von IIS und dem Neustart ist mein WAMP-Symbol vollständig verschwunden. Also habe ich IIS wieder aktiviert, aber das IIS wird nicht vollständig als "schattiert" markiert (die FTP-Option ist nicht markiert). Danach wurde ich neu gestartet und das WAMP-Symbol wurde nicht mehr angezeigt. Das passierte gestern und ich habe WAMP neu installiert, wie ich es jetzt tat, aber immer noch nichts. Auch im WAMP-Ordner gibt es keinen Apache-Ordner und auch keine Menüanzeige über das WAMP-Symbol in der Taskleiste (siehe oben). Welche andere Möglichkeit gibt es, um herauszufinden, welchen Port mein WAMP verwendet. Und ich habe kein Skype.

7

Ich hatte auch dieses Problem, es könnte ein anderes Programm auf den gleichen Ports laufen. Ich weiß, dass Skype mit Wamp- und Xammp-Servern nur schwer laufen kann.

Prüfen Sie, ob an den gleichen Ports noch etwas anderes ausgeführt wird, und deaktivieren Sie Skype = Fix:). 

edit: netstat -a -b zeigt alle empfangenden Ports und den Namen der ausführbaren Datei an .__ Wenn Sie eine grafische Version bevorzugen, zeigt Microsoft TCPView die gleichen Informationen und aktualisiert in Echtzeit.

http://technet.Microsoft.com/de-de/sysinternals/bb897437.aspx

wenn andere Programme auf den gleichen Ports laufen, müssen Sie die Ports Ihres virtuellen Servers ändern. 

9
user4433485

Ich verwende diesen Weg, um mein Problem zu lösen ... __ Klicken Sie auf das Symbol Wampserver -> Apache -> Dienstverwaltung -> Dienst installieren -> klicken Sie erneut auf das Symbol Wampserver -> Apache -> Dienstverwaltung -> Dienst starten/fortsetzen. 

Erledigt: https://www.youtube.com/watch?v=75FFNArSPvU

13
Lim Socheat

Beim Ausführen des Wampservers war ich mit dem gleichen Problem konfrontiert. Das Symbol war orange (Server offline). Bitte finden Sie die Schritte, die ich befolgt habe, um sie zum Laufen zu bringen.

  • Deinstalliert IIS, damit Apache Port 80 verwendet (DIDNTT PROBLEM NICHT BEHALTEN)

  • Ich änderte den Apache-Port von 80 in 8080 in httpd.conf, um die Dienste neu zu starten, und das Symbol wurde grün. (BEHOBEN DAS PROBLEM)

FIX, ohne den Port in httpd.conf zu ändern

Sie wollten herausfinden, welcher Dienst/welche Anwendung den Port 80 verwendet hat Führen Sie Ihre Befehlszeile als Administrator aus, und geben Sie Folgendes ein

netstat -ab

Zeigt Protokollstatistiken und aktuelle TCP/IP-Netzwerkverbindungen an.

Die Ergebnisse zeigten, dass Port 80 verwendet wurde 

TCP 0.0.0.0:80 0.0.0.0:0 LISTENING [Can not obtain ownership information]

das googeln der msg half mir, den Dienst "Web Deployment Agent Service" zu finden, der den Port verwendete. stoppte den Dienst Aktualisierte die httpd.conf, um den Port 80 erneut zu verwenden.

Bearbeiten: Legen Sie nach dem Beenden des Dienstes den Starttyp auf "Manuell" fest, um zu vermeiden, dass das Problem erneut auftritt

Weitere Einzelheiten finden Sie hier: http://benohead.com/windows-port-80-already-use/

Hinweis: Ich habe den "Web Deployment Agent-Dienst" unter "Verwaltungstools >> Dienste" gefunden (er wurde nicht im Taskmanager/Dienste aufgelistet).

Der Wampserver wurde neu gestartet, und es funktionierte, Apache verwendet jetzt Port 80. 

TCP 0.0.0.0:80 0.0.0.0:0 LISTENING [httpd.exe]

6
Priya R

Haben Sie versucht, MySQL-Ports zu wechseln? Wenn Sie bereits eine andere Version von mySQL außerhalb von WAMP installiert haben, könnten Sie auf dasselbe Problem stoßen. 

Als ich Port 3306 (standardmäßiger SQL-Port) getestet habe, wurde mir mitgeteilt, dass er von 'mysqld.exe' (aber nicht von 'wampmysqld64.exe' - WAMP-mysql) verwendet wurde. Dies war eine andere Version von MySQL, die ich zuvor auf dem Computer installiert hatte und da vergessen.

3
Konrad

Wenn das wampmanager-Menü nicht angezeigt wird, scheint es, als würden eine oder mehrere der erforderlichen MSVC-Laufzeitbibliotheken auf Ihrem System fehlen.

Es gibt eine Reihe von WampManager/Apache/MySQL/PHP. Da WAMPServer jedoch Apache-Versionen bis zu Apache 2.22 und PHP -Version zurück zu PHP5.3.5 installieren kann, ist es einfacher sicherzustellen, dass Sie über ein vollständiges Set verfügen. 

Stellen Sie sicher, dass Sie über die neueste Version dieser Microsoft C/C++ Redistributable-Laufzeitbibliotheken verfügen. Sie benötigen nicht den gesamten Compiler, nur diese C/C++ - Laufzeitbibliotheken.

FÜR WAMPServer 32bit

Weitervertreibbares Microsoft Visual C++ 2008 SP1-Paket (x86)

Umverteilbares Microsoft Visual C++ 2010 SP1-Paket (x86)

Wenn Sie WampServer 2.4 oder 2.5 32bit und daher Apache 2.4.x verwenden

Microsoft Visual C++ 2012 ist erforderlich Wählen Sie vcredist_x86.exe aus

Spätere Versionen können auch erfordern 

Microsoft Visual C++ 2014 und wählen Sie vcredist_x86.exe aus

Visual C++ Redistributable Packages für Visual Studio 2015 Update 3 und wählen Sie vcredist_x86.exe

FÜR WAMPServer 64bit

Weitervertreibbares Microsoft Visual C++ 2008 SP1-Paket (x86)

Yes you need the x86 Package regardless as
wampmanager is a 32bit exe even on a 64 bit install

Microsoft Visual C++ 2008 Redistributable Package (x64)

Weitervertreibbares Paket für Microsoft Visual C++ 2010 SP1 (x64)

Wenn Sie WampServer 2.4 64bit verwenden

Microsoft Visual C++ 2012 SP1 Redistributable Package und wählen Sie vcredist_x64.exe aus

Spätere Versionen können auch erfordern 

Microsoft Visual C++ 2014 und wählen Sie vcredist_x86.exe aus 

Visual C++ Redistributable Packages für Visual Studio 2015 Update 3 und wählen Sie vcredist_x64.exe

GROSSER HINWEIS

Die Namen dieser Laufzeitinstallationen lauten fast alle vcredist_x86.exe. Laden Sie sie herunter und installieren Sie sie jeweils einzeln. Andernfalls werden Sie sehr verwirrt.

Sobald sie installiert sind, sollten Ihre "Programme und Funktionen" ungefähr so ​​aussehen: -

32-Bit-Systeme 32bit system

64-Bit-Systeme 64bit system

1
RiggsFolly

Ich hatte auch die orange Statusfrage. Anscheinend wurde der Apache-Server, der bereits beim vorherigen Start ausgeführt wurde, nicht ordnungsgemäß beendet. Daher musste ich das durch den Task-Manager beenden, um den WAMP-Server wieder zum Laufen zu bringen.

0
avinash

Ich hatte das gleiche Problem und es wurde ein Hafenkonflikt.

Ich öffnete den Task-Manager, und ein Microsoft SQL-Prozess wurde ausgeführt .. Nach dem Beenden dieses Prozesses und dem Neustart von WAMP hat alles gut funktioniert.

0
Taylor Postoak

1 von 2 Diensten, die ausgeführt werden ......... Überprüfen Sie das Verzeichnis Ihrer Wamp-Installation .... Stellen Sie sicher, dass es sich um C handelt .... es löst mein Problem.

0
muhammad obaid

Ich habe es endlich behoben !!!
Wenn Sie einen anderen MySQL-Server für visual studio oder netbeans installiert haben, wird Port: 3306 verwendet. 
Aber für Wampsever 3 müssen Sie nur noch Rechtsklick das Wampensymbol ORANGE und dann unter mysql group einen anderen Port testen.
Es wird ein Dialog mit Port: 3307 angezeigt. 
Dann drücken Sie OK. Das ist es; dann wird das Symbol GRÜN;
Vergiss nicht zu sagen 

cout <<"YESSS!" << endl;
0

Manchmal wird auf dem Port ein Dienst ausgeführt, der vom SQL-Server oder Apache benötigt wird. 

Kopieren Sie diese Zeichenfolge und speichern Sie sie in einer .bat-Datei:

FOR /F "usebackq tokens=5" %%i IN (`netstat -aon ^| find "3306"`) DO taskkill /F /PID %%i

Ändern Sie 'find "3306" "in der Portnummer, die frei sein muss . Führen Sie dann die Datei als admin aus. Dadurch werden alle auf diesem Port ausgeführten Prozesse beendet

0
Quispie

Ich habe die vorherige ältere Version von Wamp deinstalliert, beide Dienste installiert und gestartet und funktioniert.

0
Michal Wrd

Mein Apache-Dienst hat beim Starten einen schwerwiegenden Fehler gemeldet, der in den Windows-Protokollen der Ereignisanzeige -> Anwendung gefunden werden kann. Sie können Ihren jeweiligen Fehler auch in den Ereignisprotokollen finden, wenn die Checkliste für häufige Fixes (wie das Schließen von Skype) dies nicht löst. Mein spezifischer Fehler war ein Syntaxfehler in einer Aliasdatei, die ich geschrieben habe.

0
Kevin Stubbs

Haben Sie versucht, es auf einem anderen Port auszuführen? Sie haben einfach den Port Ihres WLAN-Servers geändert und versuchen es erneut. Google herausfinden, wie der Port des Wamp-Servers geändert werden kann.

0