it-swarm.com.de

Wordpress-Installation im Unterordner funktioniert nicht mit Nginx

In nginx server installiert das Szenario Wordpress im folgenden Unterordner mydomain.com/new mit domänenspezifischer nginx-Konfiguration (conf.d/mydomain.com.conf):

server  {
listen 80;
server_name mydomain.com *.mydomain.com;
root    /var/www/mydomain;
index   index.php index.html index.htm;
# error_log  /var/log/nginx/mydomain-error.log warn;

aio threads;
    set_real_ip_from 127.0.0.1;
    set_real_ip_from 10.0.0.0/8;
    real_ip_header X-Real-IP;
    add_header      Via     "1.1 varnish-v4.1";
    gzip_vary       off; # already handled from upstream server

    include includes/cloudflare.conf;
    include includes/fastcgi-wordpress.conf;

location / {
    try_files $uri $uri/ /index.php?$args /index.php?q=$uri&$args;
    expires 30d;
}

    # Deny access to uploads that aren’t images, videos, music, etc.
    location ~* ^/wp-content/uploads/.*.(html|htm|shtml|php|js|swf)$ {
        deny all;
    }

    # Deny public access to wp-config.php
    location ~* wp-config.php {
        deny all;
    }

    # Deny access to wp-login.php. Do not enable due to admin-ajax.php!! T_T
    # location = /(wp-login|login).php {
    #    limit_req zone=one burst=1 nodelay;
    #    fastcgi_pass 127.0.0.1:9000;
    # }

    location ~ \.php$ {
            try_files $uri /index.php;
            fastcgi_pass 127.0.0.1:9000;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            include fastcgi_params;
            include includes/fastcgi-http.conf;
    }

# location ~ /purge(/.*) {
#     fastcgi_cache_purge WORDPRESS "$scheme$request_method$Host$1";
# }  

location ~* ^.+\.(ogg|ogv|svg|svgz|eot|otf|woff|mp4|ttf|css|rss|atom|js|jpg|jpeg|gif|png|ico|Zip|tgz|gz|rar|bz2|doc|xls|exe|ppt|tar|mid|midi|wav|bmp|rtf)$ {
    access_log off; 
    log_not_found off;
    expires max;
}

location = /robots.txt {
    access_log off;
    log_not_found off;
}

location ~ /\. {
    deny  all; 
    access_log off;
    log_not_found off;
}

}

Die mydomain.com läuft gut, aber in mydomain.com/new | Alle Medien und Permalinks werden an mydomain.com anstatt an mydomain.com/new weitergeleitet. Welche Konfiguration sollte geändert werden, um dies zu beheben? Ich bin neu in dieser Nginx-Konfiguration und weiß, wie man einen Fehler bei der gesamten Server/Domain verhindert, wenn die Konfiguration fehlschlägt (auf diesem Server sind mehrere Domains). Vielen Dank für die Hilfe.

1
Ivan Slaughter

Das Problem wurde behoben. Ich muss lediglich einen Standorteintrag wie folgt hinzufügen:

location /new {
    try_files $uri $uri/ /new/index.php?$args /new/index.php?q=$uri&$args;
}
2
Ivan Slaughter