it-swarm.com.de

Wie dies zu erreichen ist, hängt von den Anforderungen für libldap-2.4-2 ab

Ich versuche, das Paket libldap2-dev zu installieren.

Sudo apt-get install libldap2-dev

Ich erhalte folgenden Fehler:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libldap2-dev : Depends: libldap-2.4-2 (= 2.4.31-1+nmu2ubuntu8.2) but 2.4.31-1+nmu2ubuntu8.3 is to be installed
E: Unable to correct problems, you have held broken packages.

Es sieht so aus, als müsste ich 2.4.31-1 + nmu2ubuntu8.2 installieren, nicht 2.4.31-1 + nmu2ubuntu8.3

Ich habe es versucht:

Sudo apt-get install libldap2-dev=2.4.31-1+nmu2ubuntu8.2

Ich erhalte dabei den gleichen Fehler.

Ich habe das auch gefunden, habe aber immer noch Probleme: hier

2
ajputnam

Gelöst mit

Sudo aptitude install libldap2-dev

Zuerst schlug es vor, nichts zu tun, ich habe Nein ausgewählt, dann schlug es vor, meine aktuelle Installation auf die richtige Version herunterzustufen. Ich habe Ja gewählt.

1

zuerst solltest du synaptic installieren:

 Sudo apt-get install synaptic

und dann installiere libldap2-dev using synaptic (durch Aktivieren von libldap2-dev in synaptic)
wird sich um Abhängigkeiten kümmern.

0
sandip

Ich konnte libldap2-dev neu installieren, indem ich es zuerst entfernte und dann installierte. Hier waren die Schritte, die funktionierten

Sudo apt-get remove libldap2-dev //remove
Sudo apt-get install libldap2-dev=2.4.31-1+nmu2ubuntu8.2

Hinweis: Ich musste die Pakete entfernen, die laut libldap2-dev nicht mehr benötigt wurden. Dies wurde nach dem Sudo-Befehl apt-get remove libldap2-dev gefragt.

0
ajputnam

Versuchen Sudo apt-get install libldap2-dev checkinstall und prüfen Sie, ob dadurch die Abhängigkeiten installiert werden.

0
James