it-swarm.com.de

So installieren Sie Pakete hat keinen Installationskandidaten

Mein übergeordnetes Ziel ist die Installation von rstudio. Ich habe bereits r-base und r-base-dev installiert. Ich benutze derzeit Ubuntu 16.10 Yakkety

Wenn ich versuche zu benutzen:

Sudo dpkg -i rstudio-1.0.44-AMD64.deb  b

Ich erhalte den Fehler:

You might want to run 'apt-get -f install' to correct these.

 The following packages have unmet dependencies:
     rstudio : Depends: libgstreamer0.10-0 but it is not installable
               Depends: libgstreamer-plugins-base0.10-0 but it is not installable

Beim Versuch, Sudo apt-get install -f zu installieren, werden die Pakete nicht installiert.

Der Versuch, die Pakete direkt zu installieren, gibt diesen Fehler zurück:

 Package libgstreamer0.10-0 is not available, but is referred to by another package.
 This may mean that the package is missing, has been obsoleted, or
 is only available from another source

 E: Package 'libgstreamer0.10-0' has no installation candidate

Wenn ich versuche, Google nach diesem Paket zu durchsuchen, finde ich eine Reihe von Ergebnissen wie das folgende: https://launchpad.net/ubuntu/yakkety/AMD64/libgstreamer-plugins-base0.10- - https://launchpad.net/ubuntu/yakkety/AMD64/libgstreamer0.10-

Diese Links zeigen, dass der aktuelle Status dieser Datei "gelöscht" ist.

Meine Frage ist, was soll ich tun, wenn ich auf diese Situation stoße? Sollte ich einen Fehler melden? Laden Sie eine ältere Version des Pakets herunter?

2
ddxv

Ich konnte ältere Versionen der Pakete für Xenial herunterladen. Sie scheinen gut zu funktionieren. Dies ist das zweite Mal, dass ich diese Problemumgehung in Yakkety verwende, aber ich bin nicht sicher, ob sie normal und akzeptabel ist oder nicht.

http://packages.ubuntu.com/xenial/AMD64/libgstreamer-plugins-base0.10-0
http://packages.ubuntu.com/xenial/libgstreamer0.10-0
3
ddxv