it-swarm.com.de

Nicht erfüllte Abhängigkeiten: libc6-dbg: Abhängig von: libc6 (= 2.19-0ubuntu6.5), aber 2.19-0ubuntu6.9 ist installiert

Ich brauche wirklich eine neue Idee zu diesem Thema, abgesehen von einer neuen Installation, über die ich nachdrücklich nachdenke. Ich glaube noch nicht, dass es hier eine verwandte Lösung gibt, und Junge, wie ich versucht habe, viele mögliche Lösungen zu finden und zu versuchen. Mögen

apt-get install -f
apt-get update -f
apt-get -f install libc6-AMD64 
apt-get install libc6-dev
apt-get install libc6=2.19-0ubuntu6.5 libc6-dev=2.19-0ubuntu6.5
apt-get install libc6=2.19-0ubuntu6.9 libc6-dev=2.19-0ubuntu6.9
apt-cache depends libc6 | grep -Po 'Depends:\s+\K[^ ]+$'
apt-get install --dry-run --reinstall $(apt-cache depends libc6 | grep -Po 'Depends:\s+\K[^ ]+$' | tr '\n'

und diese Lösung.

Ich kann es nicht verwenden, da nichts installiert werden kann. Die folgende Meldung wird angezeigt:

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libc6-dbg:
    Depends: libc6 (= 2.19-0ubuntu6.5) but 2.19-0ubuntu6.9 is to be installed
 E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Auch diesmal:

[...] depends on libgcc1 (>= 1:4.1.1)

Was normalerweise so aussieht:

$ apt-cache depends libc6:AMD64 | grep -Po 'Depends:\s+\K[^ ]+$' libgcc1
$ apt-cache depends libgcc1:AMD64 | grep -Po 'Depends:\s+\K[^ ]+$'
gcc-4.9-base
libc6
multiarch-support
$ apt-cache depends multiarch-support | grep -Po 'Depends:\s+\K[^ ]+$' libc6
$ Sudo apt-get install --dry-run --reinstall $(apt-cache depends libc6:AMD64 | grep -Po 'Depends:\s+\K[^ ]+$' | tr '\n' ' ')
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libc6-dbg : Depends: libc6 (= 2.19-0ubuntu6.5) but 2.19-0ubuntu6.9 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
$ Sudo apt-get install --dry-run --reinstall $(apt-cache depends libc6-dbg:AMD64 | grep -Po 'Depends:\s+\K[^ ]+$' | tr '\n' ' ')
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libc6-dbg : Depends: libc6 (= 2.19-0ubuntu6.5) but 2.19-0ubuntu6.9 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
2
nickfaldon
 Sudo apt-get autoclean

entfernen Sie die Datei sources.list und erstellen Sie eine neue sources.list ...

Sudo rm /etc/apt/sources.list 

Dann tippe ein

Sudo software-properties-gtk 

enter image description here Dies öffnet Software-Eigenschaften-GTK und eine newsources.list wird automatisch erstellt.

Ändern Sie dann den Server in US oder einen anderen Server Ihrer Wahl. Sie müssen Repositorys im neuen Dialogfeld aktivieren, um eine neue sources.list zu erstellen.

Kreuzen Sie alle Kästchen an, klicken Sie auf Zurück und dann auf Schließen.

Standard-Repositorys müssen wiederhergestellt werden

 Sudo apt-get update && Sudo apt-get dist-upgrade -y

(Es wird empfohlen, vor der Installation eine Sicherungskopie dieser Datei zu erstellen, um in solchen Fällen eine Wiederherstellung durchzuführen.)

Jetzt alles installieren!

1
minigeek

Entfernen Sie (vorübergehend) das Paket libc6-dbg:

Sudo apt-get remove -f libc6-dbg

Es ist nicht notwendig, irgendetwas auszuführen. Sie benötigen es nur für eine hilfreichere Debug-Ausgabe, wenn Sie nach Softwarefehlern suchen.

Wenn Sie das Paket erneut benötigen, können Sie es wie jedes andere neu installieren. Wenn immer noch ein Konflikt besteht, öffnen Sie eine neue Frage und geben Sie die Ausgabe von apt-cache policy libc6 libc6-dbg ein.

1
David Foerster