it-swarm.com.de

Opencv wird mit Gstreamer kompiliert, und GStreamer wird nicht gefunden

Ich möchte opencv mit GStreamer-Unterstützung erstellen.

Ich habe den GStreamer von Source (Version 1.8.1) aus nach folgender Anleitung erstellt: http://kacianka.at/?p=145 Ich habe den Ordner 'gstreamer_build' in meinem Ordner Home-Verzeichnis und es enthält 'bin' Ordner mit diesen:

gst-device-monitor-1.0 gst-discoverer-1.0 gst-inspect-1.0 gst-launch-1.0 gst-play-1.0 gst-stats-1.0 gst-typefind -1.0 Orc-Fehlerbericht orcc

Ich habe diesen Pfad zu meiner Umgebungsvariablen PATH hinzugefügt.

Wenn ich cmake benutze:

cmake -D CMAKE_BUILD_TYPE = RELEASE -D CMAKE_INSTALL_PREFIX =/usr/local -D . ____.] ..

Die folgende Ausgabe zeigt deutlich an, dass der gstreamer nicht gefunden wurde:

-- checking for module 'gstreamer-base-1.0'
--   package 'gstreamer-base-1.0' not found
-- checking for module 'gstreamer-video-1.0'
--   package 'gstreamer-video-1.0' not found
-- checking for module 'gstreamer-app-1.0'
--   package 'gstreamer-app-1.0' not found
-- checking for module 'gstreamer-riff-1.0'
--   package 'gstreamer-riff-1.0' not found
-- checking for module 'gstreamer-pbutils-1.0'
--   package 'gstreamer-pbutils-1.0' not found
-- checking for module 'gstreamer-base-0.10'
--   package 'gstreamer-base-0.10' not found
-- checking for module 'gstreamer-video-0.10'
--   package 'gstreamer-video-0.10' not found
-- checking for module 'gstreamer-app-0.10'
--   package 'gstreamer-app-0.10' not found
-- checking for module 'gstreamer-riff-0.10'
--   package 'gstreamer-riff-0.10' not found
-- checking for module 'gstreamer-pbutils-0.10'
--   package 'gstreamer-pbutils-0.10' not found

und das:

Video I/O:
--     DC1394 1.x:                  NO
--     DC1394 2.x:                  NO
--     FFMPEG:                      NO
--       codec:                     NO
--       format:                    NO
--       util:                      NO
--       swscale:                   NO
--       resample:                  NO
--       gentoo-style:              NO
--     GStreamer:                   NO
--     OpenNI:                      NO
--     OpenNI PrimeSensor Modules:  NO
--     OpenNI2:                     NO
--     PvAPI:                       NO
--     GigEVisionSDK:               NO
--     UniCap:                      NO
--     UniCap ucil:                 NO
--     V4L/V4L2:                    Using libv4l1 (ver 1.0.1) / libv4l2 (ver 1.0.1)
--     XIMEA:                       NO
--     Xine:                        NO
--     gPhoto2:                     NO

Kann mir jemand dabei helfen?

10
Asymptote

Ich hatte das gleiche Problem.

gstreamer-base entspricht libgstbase-1.0.so (oder libgstbase-0.10.so), gefunden im Paket libgstreamer1.0-0 (bzw. libgstreamer0.10-0 , je nach Fall). Im Folgenden installieren wir das Paket '-dev'.

Die anderen Bibliotheken (libgst-video, libgst-app, libgst-riff, libgst-pbutils) habe ich in Paket libgstreamer-plugins-base1.0-dev gefunden (ersetzen Sie erneut die Version, die Sie verwenden möchten, entweder v0 .1 oder v1.0).

Daher sollte der folgende Befehl verwendet werden, um die fehlenden Abhängigkeiten zu installieren:

Sudo apt install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev

Wiederholen Sie den Befehl cmake und löschen Sie möglicherweise zuvor den Inhalt des Build-Verzeichnisses.

14
Dan0

Unter Windows gibt es kein "Sudo apt install ...". Ich hatte auch alle Pfade in meiner PATH-Umgebungsvariablen gesetzt und hatte immer noch das gleiche Problem. Ich habe diese Funktion nach Einstellung der folgenden CMake-Optionen ausgeführt:

  1. wenn Sie die Option "WITH_GSTREAMER" nur auf "True" setzen, MUSS WITH_GSTREAMER_0_10 "FALSE" sein
  2. neuen Eintrag hinzufügen "GSTREAMER_DIR" = (Pfad zu gstreamer) für mich war es "C: /gstreamer/1.0/x86_64" Ich habe diese Lösung gefunden hier

Meine OpenCV-Version: 3.4.3

0
Butterfly

Das Folgende hat für mich funktioniert, wenn Sie gerade eine Gstreamer-Anwendung entwickeln

# GStreamer CMake building
cmake_minimum_required(VERSION 3.3)
project(GStreamerHello)

set(PKG_CONFIG_USE_CMAKE_PREFIX_PATH ON)
find_package(PkgConfig REQUIRED)
if ( NOT (PKGCONFIG_FOUND))
      message(FATAL_ERROR "Please Install PPkgConfig: CMake will Exit")
endif()
pkg_check_modules(GST REQUIRED gstreamer-1.0>=1.8)
if ( NOT (GST_FOUND))
      message(FATAL_ERROR "Please Install Gstreamer Dev: CMake will Exit")
endif()
set(ENV{PKG_CONFIG_PATH})

include_directories("${GST_INCLUDE_DIRS}")

link_libraries(${GST_LIBRARIES})

add_executable(gstreamerSrvc  src/hello_gstreamer.cc)
add_dependencies(gstreamerSrvc vsphere_header )
target_link_libraries(gstreamerSrvc ${GST_LIBRARIES}  )

Hinweis - Wenn Sie ein Entwicklungsgerät für den GStreamer benötigen, finden Sie es unten. und für Ihre Frage gibt es auch die Teile des Kompilierens mit OpenCV; Weitere Details unter https://medium.com/techlogs/compiling-opencv-for-cuda-for-yolo-and-other -cnn-Bibliotheken-9ce427c00ff8

FROM nvidia/cuda
# This is a dev image, needed to compile OpenCV with CUDA
# Install  Gstreamer and OpenCV Pre-requisite libs
RUN  apt-get update -y && apt-get install -y \
            libgstreamer1.0-0 \
            gstreamer1.0-plugins-base \
            gstreamer1.0-plugins-good \
            gstreamer1.0-plugins-bad \
            gstreamer1.0-plugins-ugly \
            gstreamer1.0-libav \
            gstreamer1.0-doc \
            gstreamer1.0-tools \
            libgstreamer1.0-dev \
            libgstreamer-plugins-base1.0-dev
RUN  apt-get update -y && apt-get install -y  pkg-config \
 zlib1g-dev  libwebp-dev \
 libtbb2 libtbb-dev  \
 libgtk2.0-dev pkg-config libavcodec-dev libavformat-dev libswscale-dev \
 cmake
RUN apt-get install -y \
  autoconf \
  autotools-dev \
  build-essential \
  gcc \
  git
ENV OPENCV_RELEASE_TAG 3.4.5
RUN git clone https://github.com/opencv/opencv.git /var/local/git/opencv
RUN cd /var/local/git/opencv && \
  git checkout tags/${OPENCV_RELEASE_TAG} 
RUN mkdir -p /var/local/git/opencv/build && \
     cd /var/local/git/opencv/build $$ && \
    cmake -D CMAKE_BUILD_TYPE=Release -D BUILD_PNG=OFF -D \
    BUILD_TIFF=OFF -D BUILD_TBB=OFF -D BUILD_JPEG=ON \
    -D BUILD_JASPER=OFF -D BUILD_ZLIB=ON -D BUILD_EXAMPLES=OFF \
    -D BUILD_opencv_Java=OFF -D BUILD_opencv_python2=ON \
    -D BUILD_opencv_python3=OFF -D ENABLE_NEON=OFF -D WITH_OPENCL=OFF \
    -D WITH_OPENMP=OFF -D WITH_FFMPEG=OFF -D WITH_GSTREAMER=ON -D WITH_GSTREAMER_0_10=OFF \
    -D WITH_CUDA=ON -D CUDA_TOOLKIT_ROOT_DIR=/usr/local/cuda/ -D WITH_GTK=ON \
    -D WITH_VTK=OFF -D WITH_TBB=ON -D WITH_1394=OFF -D WITH_OPENEXR=OFF \
     -D CUDA_Arch_BIN=6.0 6.1 7.0 -D CUDA_Arch_PTX="" -D INSTALL_C_EXAMPLES=OFF -D INSTALL_TESTS=OFF ..
RUN  cd /var/local/git/opencv/build && \ 
      make install
# Install other tools you need for development
0
Alex Punnen