it-swarm.com.de

Richtige Bildschirmauflösung mit nvidia-Treibern

Ich habe eine neue Installation von Ubuntu.

Bei der Erstinstallation sind die nvidia-Treiber nicht aktiv und ich bekomme die richtige Bildschirmauflösung. 1680 x 1050

Dann installiere ich die nvidia-Treiber und die beste Auflösung, die ich bekommen kann, ist 1280x1024.

Bei der Suche in der Umgebung gibt es viele Informationen zu diesem und ähnlichen Themen. Ich habe versucht, Tipps mit xrandr, manuelles Installieren der Treiber usw. usw. zu finden. Das Finden der richtigen Informationen erweist sich jedoch als mühsam.

Ich weiß, dass die Grafikkarte die richtige Auflösung ausgeben kann, weil es tut, bis die NVIDIA-Treiber aktiviert sind. Kennt hier jemand die Lösung? (Warum muss das so schwer sein?)

Dies ist kein neues Whizz-Bang-System, sondern eines, das ich mit Ersatzteilen zusammengestellt habe.

Grafik: NV37GL Quadro PCI-E-Serie

Monitor: ViewSonic VX2025WM - Dieser Monitor funktionierte auf meinem anderen Ubuntu-System mit den NVIDIA-Treibern ordnungsgemäß, war jedoch nicht digital, sondern mit VGA verbunden.

-------------- xorg.conf ------------ nach --- 1. Installieren Sie die eingeschränkten Treiber System ---> Hardwaretreiber ---- --- 2. Wählen Sie die empfohlenen Treiber aus, installieren Sie sie und starten Sie sie neu. ------

(# nvidia-xconfig: X configuration file generated by nvidia-xconfig

(# nvidia-xconfig:  version 1.0  ([email protected])  Sun Nov  8 21:50:38 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Also, irgendwelche Vorschläge dazu? An dieser Stelle gehe ich davon aus, dass das Problem mit einem guten xorg zu tun hat. Conf-Datei und möglicherweise EDID. Eine übersichtliche Dokumentation zu diesem Thema ist schwer zu finden. Beim Durchsuchen der Foren und anderer Websites habe ich VIELE andere mit ähnlichen Problemen gefunden, aber alles ist so verstreut, dass es schwer zu sagen ist, welche keine Sackgassen sind. Angesichts der Tatsache, dass viele Posts bereits aus dem Jahr 2006 und früher stammen und dass NVIDIA-Karten so allgegenwärtig sind, ist es schwer zu verstehen, warum es keine einfachere Lösung gibt.

7
wdypdx22

Haben Sie "NVIDIA X Server-Einstellungen" in Ihrem Menü System -> Administration? Aus irgendeinem Grund arbeitet der nvidia-Treiber manchmal nicht gerne mit den normalen X-Tools.

Versuchen Sie auch, einfach /etc/X11/xorg.conf zu löschen und X neu zu starten (manchmal kann dies schwierig sein, so dass es möglicherweise einfacher ist, den Computer neu zu starten.) Wenn Sie die Datei löschen, stellt Ubuntu oder Xorg fest, dass sie fehlen und Versuchen Sie, es neu zu erstellen und erraten Sie die richtigen Einstellungen. Wenn die Einstellungen nicht zufriedenstellend sind, können Sie sie bei Bedarf ändern. Beginnen Sie jedoch erneut mit einer "sauberen" automatisch generierten xorg.conf, um sicherzustellen, dass Sie nicht durch übrig gebliebene Teile der Konfiguration gestört werden.

BITTE BEACHTEN SIE, dass dies in 9.10 für mich funktioniert hat, aber ich habe es in 10.04 nicht getestet. Wenn jemand einen Grund kennt, warum dies nicht funktioniert oder die Dinge kaputt macht, bitte melden Sie sich!

3
koanhead

Ich befand mich in genau der gleichen Situation wie das Originalposter: Die ursprüngliche UBUNTU 10.04-Installation hatte eine Auflösung von 1680 x 1050; Installation des proprietären Treibers auf maximal 1280x1024 reduziert.

Ich habe den proprietären Treiber installiert, weil mir aufgefallen ist, dass die Anzeige beim ursprünglichen Treiber offensichtlich die Anzeige (von oben nach unten) bei Änderungen "malt", anstatt das Bildschirmbild "sofort" zu aktualisieren.

Hinzufügen der "magischen Beschwörung" von

           Option"ModeValidation" "NoMaxPClkCheck"

im Device-Bereich und PRESTO wurden alle fehlenden Auflösungen erneut angezeigt (im Konfigurationsprogramm/usr/bin/nvidia-settings).

quelle: gefunden auf http://fedoraforum.org/forum/printthread.php?t=185230&pp=15&page=

6
Tomas

Eine Lösung für den Nvidia-Chipsatz: NVIDIA Graphics - Auflösungsprobleme bei neuer 12.04 LTS-Installation

xorg.conf:

Section "Monitor"
    Identifier  "Monitor0"
    VendorName  "Sanyo"
    ModelName   "LCD-32E3"
    HorizSync   30.0 - 50.0
    VertRefresh 50.0 - 60.0
EndSection

Section "Screen"
    Identifier  "Default Screen"
    DefaultDepth    24
    Option  "UseDisplayDevice" "DFP"
    Subsection  "Display"
       Modes    "1360x768" "1280x720" "720x480"
    EndSubSection
EndSection

Section "Module"
    Load    "glx"
EndSection

Section "Device"
    Identifier  "Default Device"
    Driver  "nvidia"
    Option  "NoLogo"    "True"
EndSection
1
Bob