it-swarm.com.de

Paketabhängigkeitsproblem bei der Installation von CUDA unter Ubuntu 14.04

Ich habe versucht, den Anweisungen in diesem Link zu folgen, um CUDA unter Ubuntu 14.04 zu installieren, aber in diesem Schritt habe ich ein Problem mit der Paketabhängigkeit:

~/Downloads$ Sudo apt-get install cudaReading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuda : Depends: cuda-7-0 (= 7.0-28) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Weiß jemand woran das liegen könnte?

11
Ohm

Option 1: apt-get

  1. Installieren Sie nicht erfüllte Abhängigkeiten

    Sudo apt-get install cuda-runtime-7-0
    ...
    <more unmet dependencies>
    ....
    Sudo apt-get install cuda-7-0
    
  2. Installieren Sie das Hauptpaket

    Sudo apt-get install cuda
    

Option 2: Begabung

  1. Installieren Sie aptitude

    Sudo apt-get install aptitude
    
  2. Installieren Sie das Hauptpaket

    Sudo aptitude install cuda
    
17
A.B.

Es scheint, dass Sie zuvor bestimmte nvidia-Treiber oder ein defektes cuda-Toolkit installiert haben, z. B. einige widersprüchliche Versionen aus dem Ubuntu-Repository. Daher sollten Sie diese zuerst entfernen.

Sudo apt-get purge nvidia-*
Sudo apt-get autoremove

und dann cuda installieren.

Sudo apt-get install cuda
2
Chauncey Chen

Die aktuelle Integration von GNOME mit dem CUDA-Treiber scheint Probleme zu haben (v 346.46). Ich hatte ein Problem mit login session init, konnte es aber lösen, indem ich lxde installierte und gnome und ubuntu-desktop entfernte, wie hier beschrieben: caffe installation problems

0
Ruslan