it-swarm.com.de

Nach dem Upgrade auf nvidia 375 werden die Fenster mit einem Glitch umrandet

Ich habe kürzlich ein Upgrade von nvidia-370 auf nvidia-375 durchgeführt, um CUDA/Tensorflow zu installieren, aber jetzt bekomme ich einen seltsamen Fehler. Nach dem Aufwachen aus dem Schlaf these glitchy borders erscheinen um alle Fenster und Menüelemente.

Ich hatte vorher solche Fehler, aber die Methode "pressctrl + alt + f1 und dann ctrl + alt + f7", die mit anderen Schlaffehlern funktionierte, behebt dieses Problem nicht. Kennt jemand eine Lösung für dieses Problem oder ist meine einzige Option, ein Downgrade auf den 370-Treiber durchzuführen? Ich verwende 16.04 auf Kernel 4.4.0-62-generic

11
pipsqueaker

Gleiches Problem. Mein Treiber wurde nach dem Upgrade von cuda auf nvidia-375 aktualisiert.

Ich fand das Neustarten des Fenstermanagers mit

unity --replace

dies wurde behoben, obwohl einige Fenster dabei abstürzten (z. B. Chrome).

Compiz mighty neu zu starten funktioniert auch, obwohl ich es nicht ausprobiert habe.

Edit: compiz --replace scheint dafür besser zu funktionieren, mit wenig oder keinem Fensterabsturz.

6
Sam Stainsby

Habe das gleiche Problem mit neuen Treibern (378.13). Versuchen Sie, die alte Version in den Systemeinstellungen -> Zusätzliche Treiber einzustellen. In meinem Fall mit 367,57 gut funktionieren

1
Pavlo Zamoroka

Dieser Fehler ist bereits angemeldet Launchpad Jemand hat eine temporäre Korrektur vorgeschlagen, die bei mir hervorragend funktioniert hat und die ich hier wiedergebe:

Erstellen Sie mit dem Editor Ihrer Wahl eine Datei/lib/systemd/system-sleep/fixborders mit Root-Berechtigungen. (Wenn Sie es nicht wissen, geben Sie einfach gksudo gedit /lib/systemd/system-sleep/fixborders in ein Terminal ein) mit folgendem Inhalt:

#!/bin/sh
kill $(ps -C compiz -o pid=)

Erteilen Sie dieser Datei ausführbare Berechtigungen:

Sudo chmod +x /lib/systemd/system-sleep/fixborders

Et voila!

0
Se6

Gleiches Problem hier nach dem Upgrade des NVIDIA-Treibers auf Version 375.39. Im Falle des Intel-Treibers ist alles in Ordnung. Es sieht so aus, als hätte Nvidia etwas vermasselt. Irgendeine Lösung?

Ich habe es behoben, indem ich Sudo add-apt-repository ppa hinzufügte: graphics-drivers/ppa

und installiere nvidia-370

0
s.t.e.a.l.t.h