it-swarm.com.de

Leerer Bildschirm nach der Installation des nvidia-beschränkten Treibers

Ich habe den aktuellen nvidia-eingeschränkten Treiber installiert und meinen Computer neu gestartet, und jetzt bekomme ich einen schwarzen oder leeren Bildschirm.

Wie kann ich das beheben?

105
LaMinifalda

Entfernen Sie alle Nvidia-bezogenen Pakete

  1. In ein Terminal einloggen: Ctrl+Alt+F1 (Terminal ist mit einem leeren Bildschirm sichtbar)

  2. Sudo apt-get remove --purge nvidia-*

Von vorne anfangen

  1. Sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv

Alles neu installieren

  1. Sudo apt-get install nvidia-common
  2. Sudo apt-get install xserver-xorg-video-nouveau
  3. Sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Konfigurieren Sie den X-Server neu

  1. Sudo dpkg-reconfigure xserver-xorg

Quelle: buntu Wiki

75
  1. Entfernen Sie alle Treiber, die das Problem verursachen könnten.
  2. öffne das Terminal und tippe (öffne es vom Bindestrich aus mit dem Ubuntu-Symbol in der linken Ecke)

    Sudo apt-get --purge remove nvidia
    

    oder

    Sudo apt-get --purge remove nvidia-current
    

    (Abhängig davon, welche Sie installiert haben) oder deaktivieren Sie sie in den eingeschränkten Treibereinstellungen.

  3. neustarten.

  4. geben Sie dann auf einem Terminal Folgendes ein:

    Sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
    Sudo apt-get update
    Sudo apt-get install nvidia-current nvidia-settings
    
  5. neustarten.

9
Uri Herrera

Möglicherweise funktioniert Ubuntu, verwendet aber einen anderen Kartenausgang. Für mich hat meine nVidia GeForce 7300 zwei Ausgänge, einen VGA- und einen DVI-Ausgang. Es scheint, als ob die Standardausgabe bei der Installation der Treiber DVI ist, aber ich habe keinen DVI-Monitor, so dass ich in den Wiederherstellungsmodus (verfügbar in GRUB beim Booten) gelangen konnte und Folgendes eingebe:

nvidia-xconfig --twinview --twinview-orientation="Clone"

Jetzt neu starten.

Dieser Befehl leitet die gleiche Grafik an beide Ausgänge. Von da an können Sie so lange mit diesem nVidia-Dienstprogramm experimentieren, bis Sie das bekommen, was Sie wollen. Für weitere Informationen geben Sie ein:

nvidia-xconfig -A | less

Ich hoffe, das hilft.

5
Javier Rios

In meinem Fall war es ein Problem mit dem Monitor, der meiner Nvidia-GPU eine schlechte EDID gab

Um Ihren Fehler zu beheben, können Sie diese Zeile zum Bildschirmabschnitt in der Datei /etc/X11/xorg.conf hinzufügen

Option         "ModeDebug" "true"

Überprüfen Sie nun Ihren /var/log/Xorg.0.log file.

Wenn Sie einen Fehler wie diesen finden:

NVIDIA(0): Unable to get display device DFP-0's EDID; cannot compute DPI

Anschließend können Sie das Problem beheben, indem Sie diese Zeile zum Geräteabschnitt hinzufügen

Option         "IgnoreEDIDChecksum" "DFP"

Drücken Sie Alt + Strg + F1, um zu tty1 (Terminal) zu gelangen, und führen Sie dann Folgendes aus:

Sudo apt-get --purge remove nvidia*

Dadurch werden alle NVIDIA-Treiberpakete entfernt. Wenn das immer noch nicht funktioniert, probieren Sie dies auch aus:

Sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.mybak

Dadurch wird eine beschädigte xorg-Konfigurationsdatei entfernt, falls vorhanden. Sie müssen neu starten, nachdem Sie diese Befehle ausgeführt haben. (Strg + Alt + Entf)

PS. Wenn Sie eine nvidia optimus-Karte haben, installieren Sie weder x-swat noch andere nvidia-Treiber. Die besten funktionierenden Treiber für nvidia optimus-Karten stammen von dem Hummelprojekt .

3
Sepero

Dies passierte mir beim Ausführen einer AMD-CPU: Ich habe erfahren, dass es sich um einen mit Nvidia inkompatiblen IOMMU/AMD -v-Fehler handelt. Das Deaktivieren der Virtualisierungs-BIOS-Einstellungen hat dies behoben.

2
TardisGuy

Hilft dieser Thread in Ubuntu-Foren?

Kurz gesagt, es scheint, dass die Linux-Header-Pakete für einige der Kernel (insbesondere die PAE-Kernel) nicht ordnungsgemäß installiert sind und die Kompilierung des NVIDIA-Treibers bei der Installation der NVIDIA-Pakete im Hintergrund fehlschlägt.

1
neutro

Ich habe hier alles ausprobiert und die Lösung für mich war, auf lightdm umzusteigen. Funktioniert jetzt perfekt!

0
James Heald

Beim Booten wurde ein schwarzer Bildschirm angezeigt. Ich habe eine NVIDIA 6200-Grafikkarte. Xorg.config umzubenennen und neu zu starten hat bei mir funktioniert. Die von nvidia-xconfig: version 304.51 ([email protected]) erstellte Datei xorg.config verursachte das Problem.

0
user155543

Versuchen Sie acpi=off. Das hat mein Problem mit dem Booten von leeren Bildschirmen für Ubuntu 11.10 gelöst.

0
VirusC

Das größte Problem, das ich hatte, war ein Macbook Pro zu bekommen, um die Nvidia-Treiber zu installieren !!!

Die Lösung besteht darin, die Master-Boot-Partition in EFI ENTFERNEN zu ändern und Legacy-MBP zu verwenden.

Dies wird auf einigen Webseiten diskutiert, ist aber nicht so einfach nachzuvollziehen.

https://bbs.archlinux.org/viewtopic.php?id=162289

Mit dieser Idee habe ich von einer Live-CD gebootet und dann mit Gparted die EFI-Bootpartition entfernt, von EFI in FAT32 geändert und dann mit Boot-Repair als Legacy-Boot mit der Hauptpartition mit 13.04 64-Bit neu erstellt

https://help.ubuntu.com/community/Boot-Repair

--- WARNUNG SICHERN SIE ZUERST IHRE DATEN. SIE KÖNNTEN ALLES AUF IHRER HDD AUFSCHRAUBEN ---

Legen Sie eine Live-CD ein. Starten Sie Ubuntu Run Gparted. Ändern Sie die EFI-Startpartition von EFI in FAT32.

öffne ein neues Terminal und tippe:

Sudo-Add-Apt-Repository ppa: yannubuntu/boot-repair && Sudo-Apt-Get-Update

  • Drücken Sie Enter.

  • Dann tippe:

Sudo apt-get install -y Boot-Reparatur && (Boot-Reparatur &)

Wählen Sie in der Startreparatur ERWEITERTE OPTIONEN

Deaktivieren Sie "Standard-EFI-Datei verwenden" unter "Hauptoptionen". Deaktivieren Sie "Separate/boot/efi-Partition" unter "GRUB LOCATION"

befolgen Sie die Anweisungen zur Verwendung des von Boot Repair bereitgestellten älteren Bootloaders.

Jetzt installieren und laden Sie die NVidia-Treiber so oft wie möglich

Ich habe die Methode 2 auf dieser Seite verwendet http://www.dedoimedo.com/computers/ubuntu-ringtail-nvidia.html

Ich habe wahrscheinlich 18 Stunden daran gearbeitet und JEDE verfügbare Option ausprobiert. Ich meine jeden möglichen Weg, um diese verdammten Treiber zu installieren, und dies war die einzige Lösung, die für das Macbook Pro 7.1 mit 13.04 und Nvidia_current (nvidia_304) funktioniert.

0
MB-

Ich habe auch einen leeren Bildschirm, aber dieser war auf einem Laptop mit nVidia Optimus-Karte 4200m. Optimus scheint unter Ubuntu nicht gut unterstützt zu werden. Ich musste Optimus aus dem BIOS deaktivieren und dann den Nividia-Treiber neu installieren. Mehr hier, wenn Sie lesen möchten http://developerslog.org/?p=69

0
Kaerax

Anstatt nvidia-current zu verwenden, sollten Sie wirklich versuchen, einen älteren nvidia-Treiber zu verwenden, z. die 173.xx. Dies löste das Problem für mich. Starte einfach jockey-gtk und wähle den 173.xx Treiber. Dann starten Sie Ihr System neu.

0
Wolf F.

Versuchen Sie es in /etc/default/grub:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_GFXMODE=1680x1050x32

Ersetzen Sie "1680x1050x32 |" durch Ihre native Auflösung (damit vbeinfo beim Booten in der Grub-Konsole ausgeführt wird).

Dann in /etc/grub.d/00_header:

set gfxmode=${GRUB_GFXMODE} <-- FIND THIS LINE
set gfxpayload=keep <-- ADD THIS LINE DIRECTLY BENEATH

Update grub:

Sudo update-grub

Könnte funktionieren...

0
con-f-use

Zum Titel des Themas: Was ist die aktuelle eingeschränkte nvidia-Treiberversion, die in Ubuntu natty verwendet wird?

Informationen zu Veröffentlichungen, Versionen, Fehlern und gewünschten Funktionen finden Sie unter Launchpad . Um zu verstehen, worum es geht, können Sie ihre Tour .

Die Frage zur neuesten Version des nVidia-Treibers finden Sie unter Binärpaket „nvidia-current“ in Ubuntu Natty i386 . Ab dem 20.04.2011 ist die neueste Version 270.41.06-0ubuntu1. Aber das ist nicht unbedingt die empfohlene . Die neuste für mich scheint immer fehlerhaft (wie "Zerreißen" usw.).

0
Rinzwind