it-swarm.com.de

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten: nodejs: Conflicts: npm

Ich folgte diesem Gist https://Gist.github.com/Goddard/5500157 , um nodejs und npm zu installieren, aber nach dem Ausführen konnte weder node --version noch npm --version ausgeführt werden Befehlsfehler nicht gefunden. Ich konnte nodejs deinstallieren, musste aber in das im Skript beschriebene temporäre Verzeichnis gehen und eine Deinstallation durchführen, um npm zum Verlassen zu bringen.

Bei dem Versuch, nodejs und npm erneut zu installieren, habe ich stattdessen diesen Link verwendet http://www.andreagrandi.it/2013/02/08/how-to-install-latest-stable-node-js-on -ubuntu / , aber wenn ich versuche, sowohl nodejs als auch npm zusammen zu installieren, erhalte ich diese Fehlermeldung.

Sudo apt-get install nodejs npm

The following packages have unmet dependencies:
   nodejs : Conflicts: npm
E: Unable to correct problems, you have held broken packages.

Wenn ich nur nodejs installiere, funktioniert das einwandfrei.

Sudo apt-get install nodejs

node --version
v0.10.15

Aber jetzt, wenn ich versuche, npm zu installieren, wird mir diese Fehlermeldung angezeigt

Sudo apt-get install npm 

The following packages have unmet dependencies:
npm : Depends: nodejs (>= 0.6.19~dfsg1-3) but it is not going to be installed
   Depends: nodejs-dev
   Depends: node-node-uuid but it is not going to be installed
   Depends: node-request but it is not going to be installed
   Depends: node-mkdirp but it is not going to be installed
   Depends: node-minimatch but it is not going to be installed
   Depends: node-semver but it is not going to be installed
   Depends: node-ini but it is not going to be installed
   Depends: node-graceful-fs but it is not going to be installed
   Depends: node-abbrev but it is not going to be installed
   Depends: node-nopt but it is not going to be installed
   Depends: node-fstream but it is not going to be installed
   Depends: node-rimraf but it is not going to be installed
   Depends: node-tar but it is not going to be installed
   Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Ich benutze Ubuntu 13.04. Jede Hilfe wird geschätzt. Ich weiß nicht viel über node.js und npm. Ich habe versucht zu lernen, wie man diese benutzt, also zeigt sich wahrscheinlich meine Erfahrung.

18
lumberjacked

Das nodejs -Paket, das Sie von der PPA installiert haben, enthält npm seit v0.10.0. Da Sie v0.10.15 haben, als Sie Sudo apt-get install nodejs Sie haben auch npm installiert. Versuchen Sie, npm auszuführen, um dies zu bestätigen.

Siehe auch offizielle Installationsanleitung (die, der Sie gefolgt sind, ist eine Kopie davon, aber die offizielle enthält einige zusätzliche Details).

19
cyberx86