it-swarm.com.de

Warum muss ich neu starten, um eine Verbindung zum WLAN herzustellen?

Ich verwende Ubuntu 16.04 auf meinem Laptop und fast jedes Mal, wenn ich es öffne, kann ich keine Verbindung zum WLAN herstellen. Das WLAN-Symbol im oberen Menü ist vorhanden, aber wenn ich darauf klicke, sind keine WLANs verfügbar. Ich muss meinen Computer neu starten und dann funktioniert es einwandfrei (automatische Verbindung zu einem WLAN-Netzwerk).

Warum muss ich neu starten? Gibt es eine Möglichkeit, automatisch eine Verbindung herzustellen, ohne neu zu starten?

Dieses Problem tritt jedes Mal auf, wenn ich meinen Computer anhalte. Wenn ich mich nach einem Standby anmelde, habe ich keine Internetverbindung mehr und die einzige Lösung, die ich bisher gefunden habe, ist ein Neustart ...

Hier ist die Ausgabe von lspci (ich bin jetzt verbunden)

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Skylake Integrated Graphics (rev 06)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #6 (rev f1)
00:1c.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #7 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)
07:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
08:00.0 Network controller: Intel Corporation Wireless 7265 (rev 61)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

Wenn ich nicht verbunden bin (nach Standby), sind hier die Ausgänge einiger Befehle:

Ausgabe von lsmod | grep iwl

iwlmvm                311296  0
mac80211              737280  1 iwlmvm
iwlwifi               200704  1 iwlmvm
cfg80211              565248  3 iwlwifi,mac80211,iwlmvm

Ausgabe von rfkill list all

1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2
fonfonx

Ich habe das Problem gefunden (oder zumindest einen Teil des Problems). Ich war mit einem VPN verbunden (mit OpenVPN), das anscheinend nicht richtig funktioniert. Als ich die VPN-Verbindung beendet habe (Sudo service openvpn stop) alles ging wieder gut.

Ich habe auch meinen VPN-Dienst auf dem Server neu gestartet und die Zeile AUTOSTART="none" im /etc/default/openvpn auf meinem Computer.

Allerdings weiß ich immer noch nicht, warum mein Computer nach dem Suspendieren mit dem VPN verbunden war, aber nicht nach dem Neustart ...

0
fonfonx

Versuchen Sie dies in Ihrem Terminal auszuführen

Sudo service network-manager restart 

und sehen Sie, ob das bei Ihnen funktioniert.

0
Sava