it-swarm.com.de

Ubuntu Server 18.04 ist das seltsamste Verbindungsproblem - kann extern aber nicht intern pingen

Ich verwende Ubuntu Server 18.04.1 auf einem Dell 7240-Laptop. Ich habe sowohl das Ethernet als auch das WLAN mit meinem Netzwerk verbunden (/ 24). Die IP-Adressen werden vom DHCP-Server (meinem Asus-Router) reserviert und dem Server gutgeschrieben. Als ich diese Maschine ursprünglich baute, hatte ich das gleiche Problem, das ich beschreiben werde, aber ich habe anschließend einige Dinge umgebaut und geändert, und das Problem ist bis gestern Abend verschwunden, als es wieder auftauchte.

Der Server erhält die IPs vom DHCP-Server und kann pingen und eine Verbindung zum externen Internet herstellen, Updates abrufen usw., so dass das Routing über das Gateway in Ordnung ist. Der Server kann das Gateway anpingen, aber das Gateway kann den Server nicht anpingen. Außerdem kann nichts im restlichen LAN den Server anpingen, und der Server kann auch nichts im LAN anpingen. Es ist, als ob Ubuntu Server plötzlich seine Firewall eingeschaltet hat und jeglichen Datenverkehr verweigert, mit Ausnahme des Datenverkehrs zum Internet (ich habe es übrigens überprüft und habe es nicht getan). Oder dass alle Schaltfähigkeiten plötzlich zusammengebrochen sind. Es ist so verwirrend!

Für zusätzlichen Kontext - dieses Problem trat ursprünglich auf und wie ich bereits sagte, habe ich die Maschine neu aufgebaut. Bei der Neuerstellung habe ich auch NetworkManager cli installiert, da ich es vom Desktop-Ubuntu her besser kenne und es weitere Anleitungen zur Fehlerbehebung gibt, die es verwenden. Die Dokumentation und Hilfe für netplan ist derzeit dürftig. Daher habe ich das Yaml in netplan geändert, um NetworkManager zu verwenden, und hatte einige Wochen lang eine solide Netzwerkerfahrung. Ich dachte, NetworkManager hätte dieses seltsame Problem vielleicht bis gestern Abend gelöst.

Vielen Dank im Voraus für jede Hilfe, die jemand leisten kann.

2
manners

Ich bin auf dieses Problem in der Vergangenheit mit einem Raspberry Pi-fähigen Webkiosk gestoßen, der so eingestellt war, dass er statisch eine IP-Adresse erhält, die für ein anderes Gerät reserviert war, und das Symptom war genau so, wie Sie es beschrieben haben. Konnte das Gateway pingen, konnte nicht gepingt werden und konnte nichts im Netzwerk pingen, hatte aber immer noch Internetzugang. Versuchen Sie, eine zu deaktivieren, da Ihr Server über zwei Schnittstellen verfügt. Mein Verdacht ist, dass ein MAC-Adressenkonflikt auf Seiten Ihres Routers vorliegt, der ein Problem mit der Adressreservierung verursacht.

bearbeiten: Nach einigen Nachforschungen scheint es tatsächlich, dass Ihr spezifischer Laptop Probleme mit der MAC-Adresse hat, wenn es um seinen WLAN-Chip geht.

0
Minty