it-swarm.com.de

Ubuntu 18.04 LTS WLAN-Probleme

Seit ich mir in zwei Jahren einen neuen Laptop gekauft habe, habe ich endlose Probleme mit WiFi auf meinem Laptop (Lenovo Y50-70) unter Ubuntu (16.04, 18.04).

Erstens wird die Verbindung immer von Verbindungen wie eduroam oder anderen Unternehmensverbindungen getrennt. Ich habe viele Dinge versucht, um es zu lösen, aber keine davon hat funktioniert:

  • Ändern Sie IPv6 in Ignorieren/Deaktivieren
  • Installieren/Neuinstallieren von WLAN-Treibern (Ich habe eine Broadcom-WLAN-Karte)
  • Verbindung zu einem bestimmten Zugangspunkt herstellen (iwlist-Scan und Auswahl der besten Verbindung entsprechend der Signalstärke)
  • Hinzufügen von b43 zur Blacklist
  • Secure Boot deaktivieren
  • Verwenden von Wicd Network Manager
  • Und viele andere Dinge, die im Stackoverflow oder anderswo zu finden sind ...

Meine WiFI-Kartendetails:

08:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
Subsystem: Lenovo BCM4352 802.11ac Wireless Network Adapter [17aa:0623]
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 17
Region 0: Memory at d1600000 (64-bit, non-prefetchable) [size=32K]
Region 2: Memory at d1400000 (64-bit, non-prefetchable) [size=2M]
Capabilities: <access denied>
Kernel driver in use: wl
Kernel modules: bcma, wl

Jetzt habe ich versucht, mit Treibern usw. zu spielen. Und am Ende habe ich ein größeres Problem. Wenn ich mich jetzt mit dem eduroam verbinde, kann ich es für 5-10 Minuten benutzen, nachdem es getrennt und nie wieder verbunden wurde, auch alle WiFi-Verbindungen verschwinden. Beim Trennen der Verbindung im Syslog ist folgender Fehler aufgetreten: https://Pastebin.com/FxP7PmPn Um erneut eine Verbindung herzustellen, muss der wl-Treiber gelöst und erneut gebunden werden:

Sudo rmmod wl

Sudo modprobe wl

Vielleicht kann jemand erklären, warum es mir passiert? Ist es möglich zu beheben? Ich habe es 2 Jahre lang wirklich satt ...

Ein paar Details:

  • Laptop: Lenovo Y50-70
  • Betriebssystem: Ubuntu 18.04 LTS
  • Ich habe Dual Boot mit Windows 10
  • Ich habe die WLAN-Treiber mit folgendem Befehl installiert:

    apt-get install bcmwl-kernel-source 
    

Wenn Sie weitere Informationen benötigen, lassen Sie es mich wissen.

Auch dies (Ausgabe von Befehl rfkill list all):

2: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
11: phy3: Wireless LAN
    Soft blocked: no
    Hard blocked: no
12: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Vielen Dank für jede Hilfe.

UPDATE: Ich habe einen TP-Link (TL-WN725N) WLAN-USB-Adapter gekauft und versucht, ihn mit Eduroam-Netzwerken zu verwenden. Ich kann bestätigen, dass das Problem weiterhin besteht - die Verbindung wird nach einiger Zeit getrennt und es ist sehr schwierig, erneut eine Verbindung herzustellen. Ich muss den Netzwerkmanager mehrmals neu starten oder das Modul r8188eu entladen und laden. Natürlich gibt es keine Fehler im Syslog, die ich oben gepostet habe, aber immer noch ...

6
Tomas

ENDLICH. Ich kann bestätigen, dass ich seit zwei Jahren endlich mein WLAN-Problem behoben habe. Die Lösung war eigentlich super einfach und in meiner Nähe: Ich musste REGDOMAIN in crda ändern (ich hatte dort andere Ländercodes):

  1. Sudo -H gedit /etc/default/crda

  2. REGDOMAIN=<YOUR COUNTRY CODE>

  3. neustart ( obligatorisch !! )

Sie können Ihre Landesvorwahl von hier übernehmen.

Zusammenfassend verwende ich den bcmwl-kernel-source wl-Treiber für meine Broadcom BCM4352-Karte. (gute Info/Tutorial dazu ist hier ). Ich erhalte immer noch manchmal diese Fehler und habe einige kleine Auszeiten für ~ 1 Sekunde ( keine Unterbrechungen! ), aber ich denke, es ist natürlich und es stört nicht ich im Vergleich zu dem, was ich vorher hatte ...

7
Tomas

Sudo -H gedit/etc/default/crda

REGDOMAIN = [IHR LÄNDERCODE]

neustart (obligatorisch !!)

Lustige Tatsache: funktioniert auch umgekehrt. Mein PC hatte dieses Problem und Tomas 'Lösung hat den Trick gemacht. Mein Laptop hingegen funktionierte einwandfrei, aber ich dachte, ich könnte genauso gut Vorsichtsmaßnahmen treffen. Gib meine Landesvorwahl ein und starte das System neu. Hatte genau das gleiche Problem mit der Landesvorwahl auf meinem Laptop wie ohne der Landesvorwahl auf meinem PC. Ich habe nur das, was ich geändert hatte, rückgängig gemacht, neu gestartet und alles funktionierte wieder normal. Ich verstehe nicht ganz, warum das passiert ist, aber ich wollte das trotzdem teilen. Könnte mindestens einer Person helfen. Ich hätte es einfach kommentiert, aber ich kann das noch nicht, weil ich neu bin.

0
Aaron

dies Seite kann Ihnen helfen. Eine Sache, die auch helfen kann, ist, wenn es sich um eine UEFI-Maschine handelt, die Sie zum Deaktivieren des sicheren Starts benötigen.

0
kc1di

Ich hatte dieses Problem, meine WLAN-Verbindung war extrem langsam, während es unter Windows funktionierte. Nachdem ich einige Vorschläge im Internet ausprobiert hatte, verschwand das WLAN nach einiger Zeit und kam erst nach einem Neustart des Laptops wieder. Folgendes hat für mich wie ein Zauber gewirkt (keine Probleme seit klopft an Holz):

Sudo modprobe -r rtl8723de && sleep 5 && Sudo modprobe rtl8723de ant_sel = 1

oder wenn das nicht geht:

Sudo modprobe -r rtl8723de && sleep 5 && Sudo modprobe rtl8723de ant_sel = 2

es wurde behoben.

0
Pepijn