it-swarm.com.de

Samba Share Benutzer / Passwort Fehler nach dem Update

dies ist das erste Mal, dass ich keine Antwort finden konnte. Dies ist meine erste Frage. Ich werde so viele Informationen wie möglich zur Verfügung stellen. Ich habe einen ASUS-Router mit 2 Festplatten. Es gibt nur 1 Benutzernamen/Passwort, um im Netzwerk auf die Medien zuzugreifen. Mein PC scheint nach einem Update nicht mehr darauf zugreifen zu können.

Nachdem ich die Anmeldeinformationen zum ersten Mal eingegeben und "Für immer merken" ausgewählt hatte, konnte ich immer (über 2 Jahre) auf die Laufwerke zugreifen, indem ich in Nautilus auf "Netzwerk durchsuchen" und dann auf das Routersymbol und auf den Ordner, auf den ich zugreifen möchte, klickte. Heute hatte ich ein Sicherheitsupdate, das folgendes enthielt:

Wenn ich jetzt auf die Ordner auf den Festplatten zugreife, wird Folgendes angezeigt:

Ich wähle "Registrierter Benutzer", gebe den Benutzernamen und das Passwort ein und wähle "Für immer speichern". Dann klicke auf "Verbinden" und das Kästchen erscheint wieder ausgegraut und die Felder werden auf die Standardeinstellungen zurückgesetzt.

Wenn ich erneut auf die Schaltfläche "Verbinden" klicke, wird immer wieder dasselbe abgeblendete Popup angezeigt.

Wenn ich es manuell schließe. Ein brandneues Popup-Fenster wird angezeigt, in dem ich die Anmeldeinformationen eingeben kann. Wenn ich sie jedoch erneut eingebe, wird nautilus einfach geschlossen und gelegentlich wird ein Popup mit der Meldung angezeigt, dass Ubuntu auf einen internen Fehler gestoßen ist.

Es gibt 3 Telefone, 1 Tablet, 1 Win7-PC und einen anderen Ubuntu 15.10-PC, die eine Verbindung zu den Netzwerklaufwerken herstellen und problemlos lesen/schreiben können. Ich sollte hinzufügen, dass ich das oben erwähnte Update auf dem anderen Ubuntu-PC ignoriert habe, als ich anfing, dieses Problem auf meinem zu haben.

Bisher kann ich mit meinem PC nur auf die Festplatten zugreifen, indem ich die Sicherheit meines Routers für den Samba-Zugriff deaktiviere. Ich habe wirklich keine Ahnung, wie ich hier Abhilfe schaffen oder wie ich es wieder so machen kann, wie es war.

Vielen Dank im Voraus für jede Hilfe.

8
user531897

Ich habe zuerst die Zeile client use spnego = no am Ende der Datei /etc/samba/smb.conf hinzugefügt, aber es hat nicht funktioniert. Nachdem ich die Zeile in der Nähe des Dateianfangs platziert hatte, funktionierten die Netzlaufwerke.

10
user18778

Ich hatte genau das gleiche Problem. Hinzufügen

client use spnego = no

im Abschnitt [global] von /etc/samba/smb.conf das Problem in meinem Fall gelöst. Anscheinend wurde der Standardwert nach dem Update auf v.4.3.8 auf "yes" geändert, sodass ich ihn explizit festlegen musste.

Siehe die Online-Manpage als Referenz.

10
stack_horst

Überprüfen Sie, ob Sie WinBind installiert haben. Installiere es, wenn du es nicht hast und starte samba-ad-dc erneut. Danach sollte es dir gut gehen.

https://lists.samba.org/archive/samba/2016-April/199291.html

0
Samba

Ja, nach dem letzten Update, das ich gestern durchgeführt habe, war Samba nicht in der Lage, sich als Client über den Nautilus zu verbinden. Das Mounten über den Befehl mount direct funktionierte noch. Ich musste die smb.conf-Datei wie oben vorgeschlagen durch Hinzufügen ändern

client use spnego = no

Dann müssen Sie den Samba-Netzwerk-Stack neu starten (einfach neu starten).

Alles funktioniert jetzt.

0
user534443

Danke euch allen. Ich habe das gleiche Problem. Dieser Thread gibt mir die richtige Richtung vor und hier ist, wie ich zum Fix gekommen bin. Ich habe versucht, smbclient zu verwenden, um zu sehen, was passiert ist: "SMB Server unterstützt EXTENDED_SECURITY nicht, aber 'client use spnego = yes und' client ntlmv2 auth = yes '" Ich denke, dies bedeutet, dass der Samba-Client dies mitteilt Samba-Server verwenden Funktionen, die es nicht gibt. Verwenden Sie Sambas obigen Hinweis mit dem Link: [ https://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html] [Link] Ich habe gefunden Dies: "Die Auswirkung von 'client ntlmv2 auth = yes' ist, dass wir standardmäßig keine NTLM-Authentifizierung (NT Local Machine) als Client verwenden." Da ich keine erweiterte Sicherheit verwende, deaktiviere ich diese Option einfach als "client ntlmv2" auth = no "in /etc/samba/smb.conf Ich muss eine Zeile hinzufügen, um die Standardeinstellung zu überschreiben. Alles funktioniert wieder.

0
louis