it-swarm.com.de

Qualcomm Atheros QCA6174 5Ghz Ausgabe

Ich habe ein Asus Hero Alpha-Motherboard gekauft, das mit einer Atheros Wireless-Karte geliefert wird. Die Karte ist folgende:

Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)

Die Karte funktioniert einwandfrei mit 2,4 GHz (Getestet unter Ubuntu 16.04 und 16.10). Die Probleme treten auf, wenn 5 GHz verwendet werden. Die Geschwindigkeit sinkt oft sehr schnell (Verbindung wird nicht getrennt) und bleibt aus. Wir sprechen von einer Internet- oder Lan-Geschwindigkeit, die normalerweise bei 100 Mbit/s liegt und bis zu 1,5 Mbit/s reicht.

Die einzigen Probleme, die ich beim Ausführen eines schnellen dmesg festgestellt habe, waren (Hier ist eine Zusammenfassung von dmesg sowie die Fehler):

[ 8281.488634] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 8281.488638] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 8281.488641] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 8281.488643] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[ 8281.488646] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[ 8281.488649] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 8281.488652] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 8281.488654] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 8281.488656] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 8281.508915] ath10k_pci 0000:09:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[ 8281.746038] ath10k_pci 0000:09:00.0: Direct firmware load for ath10k/cal-pci-0000:09:00.0.bin failed with error -2
[ 8281.746062] ath10k_pci 0000:09:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
[ 8281.746067] ath10k_pci 0000:09:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
[ 8283.924750] ath10k_pci 0000:09:00.0: qca6174 hw3.2 (0x05030000, 0x00340aff sub 1043:86e0) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 fwapi 4 bdapi 2 htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features wowlan,ignore-otp,no-4addr-pad
[ 8283.924766] ath10k_pci 0000:09:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 8284.001596] ath: EEPROM regdomain: 0x69
[ 8284.001600] ath: EEPROM indicates we should expect a direct regpair map
[ 8284.001603] ath: Country alpha2 being used: 00
[ 8284.001604] ath: Regpair used: 0x69
[ 8284.003776] ath10k_pci 0000:09:00.0 wlp9s0: renamed from wlan0
[ 8284.019349] IPv6: ADDRCONF(NETDEV_UP): wlp9s0: link is not ready
[ 8286.279134] IPv6: ADDRCONF(NETDEV_UP): wlp9s0: link is not ready
[ 8286.336477] IPv6: ADDRCONF(NETDEV_UP): wlp9s0: link is not ready
[ 8290.793388] wlp9s0: authenticate with d0:17:c2:3e:19:f0
[ 8290.846724] wlp9s0: send auth to d0:17:c2:3e:19:f0 (try 1/3)
[ 8290.848417] wlp9s0: authenticated
[ 8290.851753] wlp9s0: associate with d0:17:c2:3e:19:f0 (try 1/3)
[ 8290.854983] wlp9s0: RX AssocResp from d0:17:c2:3e:19:f0 (capab=0x411 status=0 aid=2)
[ 8290.857737] wlp9s0: associated

Wie Sie sehen können, ist das einzige Problem:

[ 8281.746038] ath10k_pci 0000:09:00.0: Direct firmware load for ath10k/cal-pci-0000:09:00.0.bin failed with error -2
[ 8281.746062] ath10k_pci 0000:09:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
[ 8281.746067] ath10k_pci 0000:09:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
[ 8283.924750] ath10k_pci 0000:09:00.0: qca6174 hw3.2 (0x05030000, 0x00340aff sub 1043:86e0) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 fwapi 4 bdapi 2 htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features wowlan,ignore-otp,no-4addr-pad
[ 8283.924766] ath10k_pci 0000:09:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 8284.001596] ath: EEPROM regdomain: 0x69
[ 8284.001600] ath: EEPROM indicates we should expect a direct regpair map

Ich habe eine ath10k/QCA6174/hw3.0/firmware-5.bin-Datei im System überprüft und konnte sie nicht finden. Ich habe jedoch die gesamte Ordnerstruktur dafür in /lib/firmware/ath10k/QCA6174 und ich ging sogar zu https://github.com/kvalo/ath10k-firmware , um zu überprüfen, ob es eine firmware-5.bin-Datei für die hw3.0 gab Ordner, aber es gab keine. Ich habe also ein paar Fragen dazu:

  1. Gibt es eine aktuelle (oder wird es eine aktuelle) Firmware-5.bin-Datei für hw3.0 oder war das ein Fehler im Code?

  2. Was könnte den enormen Rückgang der 5 GHz für diese Karte verursachen?

UPDATE: Bei Verwendung von 17.04 ist die WLAN-Karte jetzt schlechter. Ich habe eine 100Mbit Internetverbindung und jetzt bleibt sie einfach die ganze Zeit zurück. Jede Minute bis 2 Minuten wechselt die gesamte Funkkarte für einige Sekunden in einen sehr langsamen Geschwindigkeitszustand. Ich kann auch nicht von 2,4 GHz auf 5 GHz wechseln, ohne das Netzwerk komplett deaktivieren und dann wieder aktivieren zu müssen.

Ich bekomme das jetzt am 17.04:

TCP: wlp9s0: Driver has suspect GRO implementation, TCP performance may be compromised.
[ 4497.297536] uvcvideo: Failed to query (SET_CUR) UVC control 11 on unit 2: -110 (exp. 1).
2
Luis Alvarado

Ich teste das folgende Verfahren, das für mich die Antwort auf das Problem in den Jahren 16.04 und 17.04 sein könnte. Wenn Sie dasselbe Atheros-Modell haben, funktioniert dies für mich auf dem Asus Maximus Hero Alpha VIII

  1. Laden Sie die neuesten linux-firmware DEB-Paket aus dem buntu Linux Firmware-Ordner . Seit dem 5. Mai 2017 konnte ich Version 1.165 herunterladen

  2. Installiere es über dpkg: Sudo dpkg -i linux-firmware_1.165_all.deb

  3. Neu starten und testen.

Meine Tests wurden folgendermaßen durchgeführt, was zuvor schrecklich fehlgeschlagen ist:

  • Wechsel von 2,4 GHz auf 5 GHz. Ich habe einen ASUS AC5300 Router, der gleichzeitig 2,4 GHz und 5 GHz bietet. Die 2,4-GHz-SSID heißt Ubuntu2G und die 5-GHz-SSID heißt Ubuntu5G. Der Wechsel von einem zum anderen schlug immer fehl. Jetzt, nachdem ich nach dem Neustart 8-mal gewechselt habe, werden immer noch 2,4 GHz auf 5 GHz und umgekehrt übertragen, obwohl die Verbindung jetzt schneller hergestellt wird und die Geschwindigkeit beibehalten wird, sobald ich auswähle, mit welcher Verbindung ich verbunden werden möchte und dabei bleibe.
  • Es bereitete Kopfschmerzen, etwas auf einen Chromecast zu streamen. Jetzt kann ich sowohl das 2,4-GHz-Spektrum als auch das 5-GHz-Spektrum streamen. Es beginnt auch schneller zu streamen. Bevor ich etwa 20 bis 30 Sekunden auf den Start des Streamings warten musste, sind es jetzt etwa 2 bis 3 Sekunden.
  • Das Herunterladen aus dem Internet war vorher sehr langsam. Ich habe eine 100 Mbit/s-Geschwindigkeitsverbindung (12 Mbit/s) und die aufrechterhaltene Geschwindigkeit lag bei 1-2 Mbit/s. Jetzt bekomme ich 10MB/s bis 12MB/s. Ich habe natürlich nur 20 Minuten lang getestet, aber ich sehe effektive Geschwindigkeiten, eine gute Verbindung und eine viel bessere Gesamtleistung.
  • Dmesg wird beim Trennen, erneuten Verbinden und Verbinden auf Fehler überprüft. Beim Streaming, beim Herunterladen, beim Hochladen, beim Booten usw. Bisher werden nach dem Upgrade keine Fehler im Zusammenhang mit der WLAN-Karte angezeigt.

Aktuelle Probleme:

  • Das Ändern von 2,4 GHz auf 5 GHz funktioniert nicht. Grundsätzlich kann die WLAN-Karte keine Verbindung herstellen, und wenn ich versuche, zurückzukehren, schlägt sie fehl. Jetzt funktioniert der Wechsel von 5 GHz zu 2,4 GHz, aber wie ich bereits erwähnt habe, schlägt die Rückkehr von 2,4 zu 5 manchmal fehl.

Ich werde alle auf dem Laufenden halten, wenn dies für den nächsten Monat so bleibt.

1
Luis Alvarado