it-swarm.com.de

Probleme mit der WLAN-Verbindung unter Ubuntu 16.04

Alles hat gut funktioniert, bis ich meine Ubuntu-Version vor kurzem auf 16.04 aktualisiert habe. Meine WLAN-Verbindung wird nach jeweils 10-20 Minuten getrennt. Manchmal wird es noch schlimmer und es wird in nur 5 Minuten getrennt. Ich habe diese andere Frage in AskUbuntu gelesen und versucht, umzusetzen, was das OP als Antwort akzeptierte.

16.04 LTS WLAN-Verbindungsprobleme

Was ich bis jetzt getan habe, ist, dass ich meine WLAN-Daten verwendet habe

Sudo lshw -C network

Und hier ist was ich habe

 *-network               
   description: Wireless interface
   product: AR9285 Wireless Network Adapter (PCI-Express)
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: [email protected]:02:00.0
   logical name: wlo1
   version: 01
   serial: 78:e4:00:6f:e0:e6
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath9k driverversion=4.13.0-45-generic firmware=N/A ip=192.168.0.3 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:16 memory:c3400000-c340ffff
 *-network
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: [email protected]:03:00.0
   logical name: enp3s0
   version: 03
   serial: c8:0a:a9:d2:bf:d3
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168d-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:24 ioport:2000(size=256) memory:c1404000-c1404fff memory:c1400000-c1403fff memory:c2400000-c240ffff

Die Ausgabe für iwconfig ist:

enp3s0 keine drahtlosen erweiterungen.

lo keine Funkerweiterungen.

wlo1 IEEE 802.11 ESSID: "One Piece"
Frequenz: 2,472 GHz Zugangspunkt: 70: 62: B8: 8B: A9: 6F
Bitrate = 6,5 Mb/s Sendeleistung = 15 dBm
Kurzes Wiederholungslimit: 7 RTS thr: off Fragment thr: off Energieverwaltung: off Verbindungsqualität = 42/70 Signalpegel = -68 dBm
Rx ungültig nwid: 0 Rx ungültig crypt: 0 Rx ungültig frag: 0 Tx übermäßige Wiederholungsversuche: 1 Ungültig misc: 2293 Beacon verpasst: 0

Ich habe auch versucht, WICD zu installieren und zu verwenden, nachdem alle Konfigurationsdateien von Network-Manager entfernt wurden, aber es verliert nach 20-30 Minuten die Verbindung und wird dann durch zufälliges Trennen der Verbindung schlimmer. Irgendwelche Lösungen?

6
john400

Manchmal wird die WLAN-Verbindung aufgrund von Einstellungen im Router getrennt. Erstens sind die meisten Router standardmäßig auf die niedrigsten gemeinsamen Nenner eingestellt, einschließlich der automatischen Auswahl von WPA und WPA2, der automatischen Auswahl von AES und TKIP und, was noch schlimmer ist, der automatischen Kanalauswahl. Hier ist ein sehr interessanter Thread über die automatische Kanalauswahl und warum dies überhaupt nicht funktioniert: https://superuser.com/questions/1311149/why-do-wifi-routers-do-such-a -bad-job-of-channel-selection

Überprüfen Sie zunächst die Einstellungen im Router. WPA2-AES ist bevorzugt; kein WPA und WPA2-Mischmodus und schon gar nicht TKIP. Zweitens, wenn Ihr Router N-Geschwindigkeiten unterstützt, haben Sie möglicherweise eine bessere Konnektivität mit einer Kanalbreite von 20 MHz im 2,4-GHz-Band anstelle der automatischen 20/40 MHz, obwohl dies wahrscheinlich N-Geschwindigkeiten beeinträchtigt. Ich habe auch mehr Glück mit einem festen Kanal (1, 6 oder 11) als mit der automatischen Kanalwahl. Stellen Sie außerdem sicher, dass der Router nicht auf N-Geschwindigkeiten eingestellt ist. Auto B, G und N ist bevorzugt. Starten Sie den Router nach diesen Änderungen neu.

Als Nächstes empfehle ich, dass Ihre Regulierungsdomäne explizit festgelegt wird. Überprüfen Sie Ihre:

Sudo iw reg get

Wenn Sie 00 erhalten, ist das eine Einheitsgröße. Finden Sie Ihre hier: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Dann stellen Sie sie vorübergehend ein:

Sudo iw reg set IS

Ersetzen Sie natürlich Ihre Landesvorwahl, wenn nicht Island. Setze es dauerhaft:

Sudo nano /etc/default/crda

Ändern Sie die letzte zu lesende Zeile:

REGDOMAIN=IS

Lesen Sie es sorgfältig durch, speichern und schließen Sie den Texteditor.

Teilen Sie uns nach dem Neustart des Routers und des Computers mit, ob sich Verbesserungen ergeben.

4
chili555