it-swarm.com.de

Neuinstallation Ubuntu 16.04 kann mit NetworkManager keine Verbindung zum WLAN herstellen, aber nmtui funktioniert

Ich habe eine Neuinstallation von Ubuntu 16.04 auf meinem Asus N56VZ durchgeführt. Leider kann ich mit dem NetworkManager keine Verbindung zu drahtlosen Netzwerken herstellen. Ich kann jedoch drahtlose Netzwerke erkennen.

Ich habe versucht, über die Benutzeroberfläche eine Verbindung zu meinem Netzwerk herzustellen, und mein Kennwort eingegeben. Aber danach passiert nichts mehr. Ich sehe keinen Versuch, eine Verbindung zu diesem Netzwerk herzustellen, und erhalte auch keine Fehlermeldung. Ich kann sehen, dass der Netzwerkmanager mein Netzwerk gespeichert hat und ich habe zweimal und dreimal überprüft, ob das Kennwort und alle anderen konfigurierbaren Parameter korrekt sind.

Lustige Sache ist - ich bin in der Lage, mit nmtui ohne Probleme zu verbinden.

Ich konnte nicht testen, ob dies ein Problem mit diesem bestimmten Netzwerk ist oder ob es sich um ein allgemeines Problem handelt. Letzteres vermute ich allerdings sehr, da ich unter Ubuntu 15.04 kein Problem damit hatte, das besagte Netzwerk zu nutzen.

Ausgabe einiger interessanter Befehle:

Vor dem Verbinden mit nmtui:

iwconfig

enp4s0    no wireless extensions.

lo        no wireless extensions.

wlp3s0    IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lspci -vvnn | grep Netzwerk

03:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Subsystem: AzureWave AR9485 Wireless Network Adapter [1a3b:2c97]

Sudo-Dienst NetworkManager-Status (nachdem ich versucht habe und keine Verbindung mit dem NetworkManager herstellen konnte)

● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
   Active: active (running) since So 2016-04-24 00:03:32 CEST; 15min ago
 Main PID: 788 (NetworkManager)
    Tasks: 3 (limit: 512)
   CGroup: /system.slice/NetworkManager.service
           └─788 /usr/sbin/NetworkManager --no-daemon

Apr 24 00:18:24 Tesla NetworkManager[788]: <info>  [1461449904.2249] device (wlp3s0): state change: disconnected -> prepare (reason 'none') [30 40 0]
Apr 24 00:18:24 Tesla NetworkManager[788]: <info>  [1461449904.2253] manager: NetworkManager state is now CONNECTING
Apr 24 00:18:24 Tesla NetworkManager[788]: <info>  [1461449904.2265] device (wlp3s0): state change: prepare -> config (reason 'none') [40 50 0]
Apr 24 00:18:24 Tesla NetworkManager[788]: <info>  [1461449904.2270] device (wlp3s0): Activation: (wifi) access point 'FRITZ!Box 7362 SL' has security, but secrets are required.
Apr 24 00:18:24 Tesla NetworkManager[788]: <info>  [1461449904.2277] device (wlp3s0): state change: config -> need-auth (reason 'none') [50 60 0]
Apr 24 00:18:49 Tesla NetworkManager[788]: <warn>  [1461449929.2418] device (wlp3s0): No agents were available for this request.
Apr 24 00:18:49 Tesla NetworkManager[788]: <info>  [1461449929.2419] device (wlp3s0): state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
Apr 24 00:18:49 Tesla NetworkManager[788]: <info>  [1461449929.2422] manager: NetworkManager state is now DISCONNECTED
Apr 24 00:18:49 Tesla NetworkManager[788]: <warn>  [1461449929.2427] device (wlp3s0): Activation: failed for connection 'FRITZ!Box 7362 SL'
Apr 24 00:18:49 Tesla NetworkManager[788]: <info>  [1461449929.2437] device (wlp3s0): state change: failed -> disconnected (reason 'none') [120 30 0]

Nach dem Verbinden ergibt iwconfig:

enp4s0    no wireless extensions.

lo        no wireless extensions.

wlp3s0    IEEE 802.11bgn  ESSID:"FRITZ!Box 7362 SL"  
          Mode:Managed  Frequency:2.427 GHz  Access Point: 34:31:C4:30:7D:13   
          Bit Rate=72.2 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=66/70  Signal level=-44 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:105   Missed beacon:0

Über Anregungen würde ich mich freuen.

13
Mesaph

Ich hatte das gleiche Problem, obwohl es kein Fix ist, fand ich, dass ein Neustart des Netzwerkmanagers funktioniert. Ich habe die Anleitung dazu unten beigefügt.

Von der Kommandozeile

Beenden von Network Manager

Sudo /etc/init.d/network-manager stop

Starten von Network Manager

Sudo /etc/init.d/network-manager start
5
Kamillion

Ich habe das Problem gelöst, indem ich mein Kennwort in ein Dokument eingegeben und es dann kopiert und in das Kennwortfeld eingefügt habe.

Aus irgendeinem Grund trat eine Zeitüberschreitung bei der Verbindung auf, bevor ich mein (langes) Passwort eingeben konnte, aber keine Nachrichten darüber erhielt.

3
Anna

ubuntu 16.04 hat den Wireless-Treiber nicht richtig konfiguriert. Ich habe Ubuntu 16.04 auf drei Computern installiert und niemand kam mit dem Arbeiten mit Wireless. Eine einfache Lösung könnte sein, das Benutzer-Ethernet-Kabel für die Nutzung des Internets zu verwenden

  • Sudo apt-get update
  • jetzt gehe zu> Systemeinstellungen> Software-Updates> Zusätzlicher Treiber
  • wenn nun der WLAN-Treiber angezeigt wird, installieren Sie ihn und Sie sind fertig.

Wenn es Ihr Problem nicht löst, müssen Sie wahrscheinlich Protokollierungstools wie dmesg, syslog, journalctl, lshw ... verwenden, um Ihre drahtlose Hardware zu kennen und den entsprechenden Treiber zu googeln.

3
user545033