it-swarm.com.de

Netzwerk deaktiviert - Gerät nicht bereit 16.04

Laptop : Acer V 13
kein vorinstalliertes Betriebssystem. Frisch installiertes Ubuntu 16.04.

Wenn ich in der oberen rechten Ecke auf den Netzwerkmanager klicke, werden keine WLAN-Netzwerke gefunden, und stattdessen wird der Text device not ready abgeblendet.

Ethernet-Kabel funktioniert (so poste ich das ...)

Ich arbeite mit vielen Netzwerken und Benutzern zusammen, sodass ich weiß, dass das Problem an meinem Ende liegt.

Nachstehend finden Sie alles, was ich versucht habe, gefolgt von allen Informationen, die ich für relevant hielt.

Ich habe auch angemeldet das Ergebnis dieses Skript , das einige zusätzliche Informationen enthält, und angebundenes Syslog für eine Weile.

Danke im Voraus, du rockst! :)


Dinge, die ich ausprobiert habe :

  1. $ Sudo service network-manager start
    (Keine Leistung)
  2. $ Sudo service network-manager stop && Sudo service network-manager start
    Keine Ausgabe, Netzwerksymbol verschwindet und erscheint wieder in der Taskleiste
  3. $ Sudo ifup lo ifup: interface lo already configured
  4. $ Sudo ifup enp2s0 Unknown interface enp2s0
  5. mit wicd network manager
    Ich habe auch kein drahtloses Netzwerk gefunden.
    (Eigentlich bin ich froh, dass es nicht geklappt hat. Scheint sowieso eine schlechte Idee zu sein.)
  6. $ Sudo service networking restart
  7. $ Sudo service NetworkManager restart
  8. $ Sudo echo "blacklist ath10k_pci" >> /etc/modprobe.d/blacklist.conf
    Nach dem Neustart wurde im Menü des Netzwerkmanagers in der Taskleiste kein Verweis auf WLAN angezeigt
  9. $ Sudo apt-get install bcmwl-kernel-source
    `` `
    Lesen von Paketlisten ... Fertig Erstellen eines Abhängigkeitsbaums
    Statusinformationen werden gelesen ... Fertig Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt: gksu libgksu2-0 libglade2-0 python-cairo python-dbus python-gi python-glade2 python-gobject python-gobject- 2 python-gtk2 python-notify python-wicd wicd-daemon Verwenden Sie 'Sudo apt autoremove', um sie zu entfernen. Die folgenden zusätzlichen Pakete werden installiert: dkms Die folgenden NEUEN Pakete werden installiert: bcmwl-kernel-source dkms 0 aktualisiert, 2 neu installiert, 0 zu entfernen und 315 nicht aktualisiert. Benötigt 1581 kB an Archiven. Nach diesem Vorgang werden 8278 KB zusätzlicher Speicherplatz verwendet. Möchtest du weiter machen? [Y/n] Get: 1 http://pl.archive.ubuntu.com/ubunt xenial-updates/main AMD64 dkms all 2.2.0.3-2ubuntu11.1 [66,2 kB] Get : 2 http://pl.archive.ubuntu.com/ubunt xenial/restricted AMD64 bcmwl-Kernel-Quelle AMD64 6.30.223.248 + bdcom-0ubuntu8 [1515 kB] 1581 kB in 0s (4809) abgerufen kB/s)
    Auswahl eines zuvor nicht ausgewählten Pakets dkms. (Datenbank wird gelesen ... 206160 Dateien und Verzeichnisse sind derzeit installiert.) Vorbereiten des Entpackens .../dkms_2.2.0.3-2ubuntu11.1_all.deb ... Entpacken von dkms (2.2.0.3-2ubuntu11.1) ... Auswählen zuvor nicht ausgewähltes Paket bcmwl-kernel-source. Vorbereiten des Entpackens .../bcmwl-kernel-source_6.30.223.248 + bdcom-0ubuntu8_AMD64.deb ... Entpacken von bcmwl-kernel-source (6.30.223.248 + bdcom-0ubuntu8) ... Verarbeiten von Triggern für man-db ( 2.7.5-1) ... dkms (2.2.0.3-2ubuntu11.1) einrichten ... bcmwl-kernel-source (6.30.223.248 + bdcom-0ubuntu8) einrichten ... Neues bcmwl-6.30.223.248 laden + bdcom DKMS-Dateien ... Erste Installation: Alle Kernel prüfen ... Nur für 4.4.0-34 generisch erstellen Für Architektur erstellen x86_64 Erstes Modul für 4.4.0-34 generisch erstellen Fertig. wl: Überprüfung der Modulversion.

    • Originalmodul
      • In diesem Kernel ist kein Originalmodul vorhanden
    • Installation
      • Installation in /lib/modules/4.4.0-34-generic/updates/dkms/depmod .... DKMS: Installation abgeschlossen. modprobe: ERROR: 'wl' konnte nicht eingefügt werden: Erforderlicher Schlüssel nicht verfügbar tools (0.122ubuntu8) ... update-initramfs: Generierung von /boot/initrd.img-4.4.0-34-generic W: Möglicherweise fehlende Firmware /lib/firmware/i915/skl_guc_ver6.bin für Modul i915_bpo `` `
  10. signiertes und geladenes Modul wl:

$ openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=awesome key/" $ Sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n wl) $ Sudo mokutil --import MOK.der $ reboot $ Sudo modprobe wl # no error output this time :)

  1. einige Pakete neu installieren: $ Sudo apt-get purge bcmwl-kernel-source $ Sudo apt-get install build-essential dkms linux-headers-generic $ Sudo apt-get update $ Sudo apt-get install bcmwl-kernel-source $ modprobe -r b43 bcma $ modprobe -r brcmsmac bcma $ modprobe -r wl $ modprobe wl $ reboot

Relevante Informationen:

$ rfkill list
0: Acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

-

$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

-

$ iwconfig
wlp3s0    IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

enp2s0    no wireless extensions.

lo        no wireless extensions.

-

$ Sudo lshw -c network
  *-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: enp2s0
       version: 15
       serial: 30:65:ec:9a:29:e2
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.0.103 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:124 ioport:3000(size=256) memory:a1204000-a1204fff memory:a1200000-a1203fff
  *-network DISABLED
       description: Wireless interface
       product: QCA6174 802.11ac Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:03:00.0
       logical name: wlp3s0
       version: 32
       serial: c8:ff:28:00:90:51
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath10k_pci driverversion=4.4.0-34-generic firmware=WLAN.RM.2.0-00180-QCARMSWPZ-1 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:127 memory:a1000000-a11fffff

-

lspci -knn | grep Net -A2
03:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
    Subsystem: Lite-On Communications Inc QCA6174 802.11ac Wireless Network Adapter [11ad:0807]
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci, wl

-

in der nächsten Datei habe ich versucht, managed=true zu setzen und neu zu starten, bis irgendwo wieder managed=false angezeigt wurde.

$ cat  /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

-

    $ dmesg | grep "\(disabled\|switch\)"
[    0.000000] x86/fpu: Using 'eager' FPU context switches.
[    0.000000]   6 disabled
[    0.000000]   7 disabled
[    0.000000]   8 disabled
[    0.000000]   9 disabled
[    0.000000] ACPI: Early table checksum verification disabled
[    0.069778] DMAR-IR: x2apic is disabled because BIOS sets x2apic opt out bit.
[    0.237651] pci 0000:00:14.0: System wakeup disabled by ACPI
[    0.244497] pci 0000:00:1c.0: System wakeup disabled by ACPI
[    0.245318] pci 0000:00:1c.4: System wakeup disabled by ACPI
[    0.246125] pci 0000:00:1c.5: System wakeup disabled by ACPI
[    0.248614] pci 0000:00:1f.3: System wakeup disabled by ACPI
[    0.249896] pci 0000:02:00.0: System wakeup disabled by ACPI
[    0.256218] pci 0000:03:00.0: System wakeup disabled by ACPI
[    0.937596] audit: initializing netlink subsys (disabled)
[    0.942695] Console: switching to colour frame buffer device 240x67
[    0.970222] i8042: PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp
[    1.103625] fb: switching to inteldrmfb from EFI VGA
[    1.103641] Console: switching to colour dummy device 80x25
[    1.254041] Console: switching to colour frame buffer device 240x67
[ 1117.284285] xhci_hcd 0000:00:14.0: System wakeup disabled by ACPI
[ 1117.292227] rtc_cmos 00:03: System wakeup disabled by ACPI
[ 1117.292230] r8169 0000:02:00.0: System wakeup disabled by ACPI

-

$ ifconfig
enp2s0    Link encap:Ethernet  HWaddr 30:65:ec:9a:29:e2  
          inet addr:192.168.0.103  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:26514 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18223 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:32858129 (32.8 MB)  TX bytes:2703210 (2.7 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2379 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2379 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:217304 (217.3 KB)  TX bytes:217304 (217.3 KB)

-

1
Adam Goldman

Ich weiß nicht warum es funktioniert hat, hier ist was ich getan habe:

Gesichert /lib/firmware/ath10k/QCA6174
Ersetzt durch https://github.com/kvalo/ath10k-firmware/tree/master/QCA6174
Neu gestartet

Zu diesem Zeitpunkt war WLAN vollständig aus dem Menü des Netzwerkmanagers verschwunden.
Also habe ich den ursprünglichen QCA6174-Ordner wiederhergestellt, neu gestartet und es funktioniert jetzt!

Als gelöst markieren.
Wenn jemand weiß, warum das funktioniert hat, bin ich sehr neugierig ...

1
Adam Goldman