it-swarm.com.de

Es ist kein Ping oder Zugriff auf Gast von Host-vmware möglich

Ich habe Win7 OS mit VMware Workstation mit Debian 7. Dies ist die IPconfig von Host (Win 7)

   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 10.47.235.94
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . : 0.0.0.0

Ich bin über NAT verbunden (ich konnte keine überbrückte Verbindung herstellen). ifconfig des Gastes ist dies

debian 7 ifconfig - vmware

Wenn Sie jedoch einen Gast vom Host per IP 192.168.252.138 anpingen, wird die Zeitüberschreitung der Anforderung überschritten. Wenn ich einen Netzwerkadapter von Win7-Netzwerkverbindungen aktiviere, sagen Sie VMnet1, erscheinen diese Zeilen entsprechend in win7 ipconfig

Ethernet adapter VMware Network Adapter VMnet1:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::4561:18cc:8abc:93a2%15
   IPv4 Address. . . . . . . . . . . : 192.168.71.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

und ich kann Host vom Gast per 192.168.71.1 ping, aber nicht erneut Gast vom Host (dies ist was ich brauche).

Ich habe keine Firewall-Regeln in guest: /sbin/iptables -L zeigt keine Regeln. 

Ich bin in der Lage, ein benutzerdefiniertes virtuelles Netzwerk zu erstellen und einen Gast damit zu verbinden. Dabei kann ich eine statische IP-Adresse festlegen. In diesem Fall kann ich eine Verbindung vom Host zum Gast herstellen, aber das Problem ist, dass ich vom Gast keine Verbindung zum Internet herstellen kann.

vielen Dank

13
dav

anstelle von vmnet1 musste ich VMware Network Adapter VMnet8 aktivieren, wodurch der Konfig des Hosts Folgendes hinzugefügt wurde

Ethernet adapter VMware Network Adapter VMnet8:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::28e4:a65d:b520:ad92%16
   IPv4 Address. . . . . . . . . . . : 192.168.252.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

danach konnte ich den Gast vom Host aus pingen. Der Verbindungstyp zwischen Host und Gast ist nat.

Update

wenn es bereits aktiviert ist, kann das Deaktivieren und erneute Aktivieren hilfreich sein (danke Paul G)

29
dav

Lassen Sie das hier einfach, wenn jemand auf dieses Problem stößt und keine Lösung findet.

Es ist offensichtlich, aber stellen Sie sicher, dass Ihr Gast, wenn Sie Windows ausführen, tatsächlich auffindbar ist.

Geben Sie beim Start "HomeGroup" ein und ändern Sie entweder den Netzwerkpfad in "private" oder gehen Sie zu "Erweiterte Freigabeeinstellungen ändern" und legen Sie die entsprechenden Berechtigungen für public fest. 

Es ist eines dieser kleinen Details, die leicht übersehen werden können ... 

4
Xenocide

[Virtual Network Editor] legt ISO-OSI-Layer-1 & 2 fest

.. eine physikalische Abstraktion auf physischen Medien und eine Steuerschicht aus CSMA/CD für Ethernet-LANs

Ihr Setup hatte, in derselben VMne1-CSMA/CD-Domäne, zwei getrennte Schicht-3-Netzwerkadressendefinitionen:

W7 was an L2 CSMA/CD-VMnet1 connected [Host] on an L3 [network]  10.47.235.94/32
W7 had an L2 CSMA/CD-VMnet1 setup            as an L3 [network] 192.168.71.0/24   #(*) 
VM was an L2 CSMA/CD-VMnet1 connected [Host] on an L3 [network] 192.168.252.0/24

und außer der offensichtlich nicht übereinstimmenden Konfiguration (^ *), es gab kein L3 [Netzwerk] Verschaltung über eine [router ], um zwischen den beiden diskjunkten Welten eine IP-routingfähige Verbindung herzustellen.

Das wird niemals fliegen

Richten Sie entweder eine Rolle [router] ein, oder konfigurieren Sie L3- "übereinstimmende" Adressen, oder wechseln Sie zu einem separaten VMnet (und VmWare "routet" für Sie).

0
user3666197