it-swarm.com.de

phpMyAdmin - Fehler Sie sollten ein Upgrade auf MySQL 5.5.0 oder höher durchführen

Ich habe phpMyAdmin-4.2.9.1-english auf einer Centos 6.5-Plattform installiert.

2.6.32-431.23.3.el6.x86_64 # 1 SMP Do 31.07 17:20:51 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Wenn ich mich anmelde, erhalte ich den folgenden Bildschirm:

phpMyAdmin - Error

You should upgrade to MySQL 5.5.0 or later.

Ich verwende Server-Version: 5.1.73

Was soll ich machen?

16
user3400327

Ich ging zu /usr/share/phpMyAdmin/libraries/common.inc.php und __. Kommentierte diese Zeilen aus: 

    #if (PMA_MYSQL_INT_VERSION < 50500) {
    #    PMA_fatalError(
    #        __('You should upgrade to %s %s or later.'),
    #        array('MySQL', '5.5.0')
    #    );
    #}

und jetzt kann ich mein mysql administrieren.

UPDATE:

http://docs.phpmyadmin.net/de/latest/faq.html#faq1-17 erklärt aber nicht warum

warum :

https://sourceforge.net/p/phpmyadmin/bugs/4437/

https://github.com/phpmyadmin/phpmyadmin/commit/9112d7c9303b51b7e156cc98fa79ab8824b50e30

36
Sérgio

Diese spezielle Version von phpMyAdmin wurde für modernere MySQL-Versionen entwickelt. Um das Problem zu beheben, können Sie entweder Ihre MySQL-Installation aktualisieren oder phpMyAdmin herunterstufen. Ein Upgrade von MySQL erfordert wahrscheinlich ein Upgrade auf CentOS 7, daher sind Sie wahrscheinlich nicht dazu bereit. Glücklicherweise unterstützt das phpMyAdmin-Team derzeit den Zweig 4.0.x, für den nur MySQL 5 oder neuer und PHP 5.2 oder neuer erforderlich ist. Sie können also 4.0.10.4 (oder was auch immer die aktuelle Version 4.0.x ist) von http://www.phpmyadmin.net/home_page/downloads.php herunterladen (wo Sie auch die aufgelisteten Anforderungen und das erwartete Ende sehen können von Lebensdaten).

8
Isaac Bennetch

Wenn Sie PHPMyAdmin verwenden möchten, empfehlen Sie ein Upgrade Ihrer MySQL-Version auf die neueste Version. Dies ist aus Sicherheitsgründen sehr wichtig. Folgen Sie dazu einfach einigen einfachen Schritten:

. Exportieren Sie alle Ihre Datenbanken und sichern Sie die Sicherung auf Ihrem lokalen System. Aktualisieren Sie Ihre MySQL-Version auf die neueste Version. Importieren Sie Ihre gesamte Datenbank erneut aus dem PHPMyAdmin-Bedienfeld.

Komplette Tutorials für den Export/Import von Datenbanken aus PHPMyAdmin ...

Sie sollten nicht viel Problem außer Kennwortproblem für bereits erstellte Datenbankbenutzer erhalten. Setzen Sie einfach das Passwort zurück, um es zu beheben.

1
Herbal

Dieser Fehler wurde nur für einen Benutzer auf meinem Cpanel-Hosting-Server angezeigt.

Ich habe die max_questions: max_updates: max_connections: max_user_connections:-Werte für den Benutzer geändert, der mit dem Problem konfrontiert ist, von "1" to "0".

Post dieses Phpadmin begann zu arbeiten.

0
Prateek_N

Ich habe das Upgrade durchgeführt, und alles läuft zur Hölle. Ich empfehle, die Strings komplett zu entfernen und eine saubere MySQL-Installation durchzuführen, um Kopfschmerzen zu vermeiden. Für eine Testumgebung können Sie die Hackantwort verwenden, indem Sie die Zeilen in der Datei "/usr/share/phpMyAdmin/libraries/common.inc.php" kommentieren oder vor der Installation von mysql die mysql-repo-Anzeige herunterladen und installieren an die PMA. Viel Glück.

0
Carlord

Verwenden Sie die Anweisungen hier, um mysql repo einzurichten und aktualisieren Sie Ihre mysql auf die neueste Version:

http://dev.mysql.com/doc/mysql-repo-excerpt/5.6/de/updating-yum-repo.html

Es ist besser, als phpmyadmin herunterzuhacken oder eine alte MySQL-Version zu verwenden.

0
a20