it-swarm.com.de

Gedit auf OSX Mavericks ausführen?

Die Version von Gedit auf der Website gnome.org scheint nicht unter OSX Mavericks zu laufen. Gibt es eine Möglichkeit, dies zu beheben? 

18
Jasper Blues

Als ich es ausprobierte, war das Problem die mit gedit gepackte Version von libxml2.

Verwenden Sie den Befehl " brew install libxml2".

dann cp /usr/local/Cellar/libxml2/2.9.1/lib/libxml2.2.dylib /Applications/gedit.app/Contents/Resources/lib/.

In der aktuellen Version von brew hat sich das Verzeichnis zu 2.9.2 geändert: Dann cp /usr/local/Cellar/libxml2/2.9.2/lib/libxml2.2.dylib /Applications/gedit.app/Contents/Resources/lib/.

27
ColinKinloch

Nachdem ich MacPorts installiert hatte und Kommentare von oben hatte, konnte ich einfach rm /Applications/gedit.app/Contents/Resources/lib/libxml2.2* und es verwendete die system/macports-Bibliothek anstelle der mitgelieferten ohne Fehler.

12
EkriirkE

Nur zur Überarbeitung:

  • Macports korrekt installiert haben. (Wenn Sie gerade von beispielsweise OSX Lion aktualisiert haben, müssen Sie macports auf Ihr neues Maverics OSX-System, https://trac.macports.org/wiki/Migration ) migrieren.

  • Gedit-3.2.6-3 wird heruntergeladen 

  • Sudo port install libxml2

  • und rm /Applications/gedit.app/Contents/Resources/lib/libxml2.2* 

  • Öffnen Sie gedit und starten Sie die Codierung!

Für mein 13-Zoll-Macbook Pro von Anfang 2011 hat es gut funktioniert.

-

Wenn Sie gedit von Terminal aus verwenden möchten:

hinzufügen 

alias gedit = "open -a gedit"

zu 

~/.bash_profile 

Ich habe festgestellt, dass die mit Gedit 3.2.6 vertriebene Version von "libxml2.2.dylib" veraltet ist.

Installieren Sie "Xcode" aus dem App Store (falls noch nicht geschehen).

$ cp -p /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/lib/libxml2.2.dylib /Applications/gedit.app/Contes/Resources /lib/libxml2.2.dylib

1
Friedrich S

Gedit 2.30.2 funktioniert. Aber Ihr eigenes Plugin funktioniert nicht mit Gedit 2.30.2.

1
Hong

Ich weiß nicht, was Ihr Ziel ist, aber ich habe mit einem anderen Programm einen leichteren Weg gefunden. Wenn die Installation all dies anfängt, umständlich zu werden (was ich zumindest herausgefunden habe, da xcode heruntergeladen und manipuliert werden musste), fand ich, dass sublime Text 2 sehr gut funktioniert.

1
user2955833

probiere Version 2.26.3 von Gedit - es arbeitet für mich an MOJAVE! http://ftp.gnome.org/pub/GNOME/binaries/mac/gedit/2.26/ Darek

0
Darek

Eine Lösung (ich interessiere mich immer noch für andere) ist folgende: 

  • Die neueste Version von Gedit (3.2.6-3) für OSX auf der Gnome.org-Website stürzt ab. 
  • Der ältere Gedit 2.30.2 läuft noch. 
0
Jasper Blues