it-swarm.com.de

Suse Enterprise 11 SP2 So installieren Sie git

Ich hatte noch nie ein Problem bei der Installation von git auf einer Linux-Distribution, aber jetzt bin ich gezwungen, einen Client-Server zu verwenden, den SLES 11 SP2. Es verwendet yast oder zypper für die Paketverwaltung, die ich noch nie verwendet habe. Anscheinend sollte ich zypper install git-core können, aber das funktioniert nicht, weil ein gewisses Repo hinzugefügt werden muss. Natürlich ist nichts davon auf der offiziellen Git-Installationsseite hier .

Ich habe herausgefunden, welche Pakete zum SLE11-SP2-SDK-Repo hier gehören. Keine Anweisungen, wie Sie das Repo zu Yast oder Zypper hinzufügen.

Ich akzeptiere auch eine Antwort, die mir sagt, wie man git auf einem SLES-Server installiert. Ich habe es bereits von Source aus versucht, aber es fehlen natürlich die Voraussetzungen, die auch zum SDK-Repo gehören.

Das bekomme ich, wenn ich "zypper install git-core" mache:

$ Sudo zypper install git-core

Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
'git-core' not found in package names. Trying capabilities.
No provider of 'git-core' found.
Resolving package dependencies...

Nothing to do.
26
Brade

Ich habe es herausgefunden, nur durch Zusammenfügen anderer Informationen, hauptsächlich aus dem OpenSUSE-Projekt .. _. Im Grunde ist es:

$ Sudo zypper addrepo http://download.opensuse.org/repositories/devel:/tools:/scm/SLE_11_SP2/devel:tools:scm.repo
$ Sudo zypper install git-core
53
Brade

git ist Teil des SDK für SLES, das hier heruntergeladen werden kann:

http://download.novell.com (idealerweise für das aktuell verwendete SP2)

Nachdem Sie itm installiert haben, funktionieren die Befehle zypper oder yast. Es wird nicht empfohlen, openSUSE-RPMs in einer SLES-Umgebung zu verwenden.

5
user1571656

In zypper müssen Sie das Repository von git mit dem Befehl zypper addrepo <repo_url> hinzufügen, bevor Sie versuchen, es zu installieren. Sie können die Repo-URL von git package hier herunterladen. 

0
rashok

Sie müssen die SLES 11 SP2 SDK - DVD von download.suse.com herunterladen. Um auf die Downloads zugreifen zu können, müssen Sie ein Benutzerkonto registrieren (es ist kostenlos).

  1. Mounten Sie nach dem Download die erste DVD. (stellen Sie sicher, dass es für die richtige Architektur ist)

  2. Laden Sie YaST und gehen Sie zu Software-> Add-On-Produkte.

  3. Wählen Sie dann 'Hinzufügen' und setzen Sie die Installation fort, indem Sie die Installationsquelle auswählen, die Lizenz akzeptieren usw.

  4. Wiederholen Sie dies für DVD2, es sei denn, DVD1 hatte alles, was Sie brauchten.

0
Marmoy