it-swarm.com.de

Paket linux-headers-4.15.0-kali2-AMD64 konnte nicht gefunden werden

Ich versuche, apt-get install linux-headers-$(uname -r).__ auszuführen, bekomme aber eine Fehlermeldung.

E: Unable to locate package linux-headers-4.15.0-kali2-AMD64
E: Couldnt find any package by glob 'linux-headers-4.15.0-kali2-AMD64
E: Couldnt find any package by regex'linux-headers-4.15.0-kali2-AMD64

Also hier ist das Ding, ich ändere source.list mit ( https://docs.kali.org/general-use/kali-linux-sources-list-repositories ) diesen Repositories (die Links). Ich denke, meine Version von kali stimmt nicht mit den Links überein. Wenn ich apt-cache search linux-headers schreibe, scheint meine Kopfzeile wie linux-headers-4.16.0-kali2-all ...

Gibt es einen Vorschlag? Wie kann ich dieses Problem lösen? Oder gibt es einen Link zur Version 4.16.0?

5
Caner Taşan

Ich hatte das gleiche Problem mit Kali und bekam es durch das Aktualisieren von Linux-Image- und Linux-Header-Paketen zum Laufen:

apt-get update && apt-get upgrade
apt-cache search linux-image

suchen Sie dann nach latest linux-image und linux-source-Paketen mit derselben Version. In meinem Fall war die Ausgabe

linux-headers-4.17.0-kali1-AMD64 - Header files for Linux 4.17.0-kali1-AMD64
linux-headers-4.17.0-kali1-cloud-AMD64 - Header files for Linux 4.17.0-kali1-cloud-AMD64
linux-image-4.17.0-kali1-AMD64 - Linux 4.17 for 64-bit PCs
linux-image-4.17.0-kali1-AMD64-dbg - Debug symbols for linux-image-4.17.0-kali1-AMD64
...

also habe ich gerade die neuesten versionen installiert:

apt-get install linux-headers-4.17.0-kali1-AMD64 linux-image-4.17.0-kali1-AMD64 -y
reboot
7
thev0id

Ich konnte auf die neueste Kali-Version (4.17.0) aktualisieren, indem Sie diesen Befehl ausführen:

Sudo apt-get install --reinstall linux-image-4.17.0-kali3-AMD64
1
Tomer