it-swarm.com.de

"libevent not found" Fehler in tmux

Ich versuche, tmux auf meinem Scientific Linux-Computer der Version 6.5 (Carbon) zu installieren

Dies sind die Schritte, denen ich gefolgt bin

wget http://downloads.sourceforge.net/tmux/tmux-1.9.tar.gz

tar xvzf tmux-1.9.tar.gz

cd tmux-1.9

./configure

In diesem Schritt wird der Fehler angezeigt:

configure: error: "libevent not found" 



Um es zu lösen, habe ich folgendes getan:

emacs /etc/yum.repos.d/pgdg-92-sl.repo


und fügte die folgenden Zeilen hinzu

[pgdg92]
name=PostgreSQL 9.2 $releasever - $basearch
baseurl=http://yum.postgresql.org/9.2/redhat/rhel-6.4-$basearch
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG-92

[pgdg92-source]
name=PostgreSQL 9.2 $releasever - $basearch - Source
failovermethod=priority
baseurl=http://yum.postgresql.org/srpms/9.2/redhat/rhel-6.4-$basearch
enabled=0
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG-92

Dann tat:

yum install libevent



Es wurde korrekt installiert

Immer noch der Fehler konfigurieren: error: "libevent not found" ist nicht gelöst

Danke im Voraus :)

39
Anand

Wenn Sie versuchen, Software zu erstellen, benötigen Sie das Entwicklungspaket. Installieren libevent-devel.

Für Ubuntu-basierte Distributionen ist das Paket libevent-dev

106