it-swarm.com.de

Wie öffne ich phpMyAdmin? Ich habe PHP Skriptausgabe

Wie öffne ich phpMyAdmin? Wenn ich mein localhost/phpmyadmin öffne, habe ich PHP Skriptausgabe, aber nicht die phpMyAdmin-Schnittstelle.

http://i.stack.imgur.com/zfoJi.png
(Zum Vergrößern auf das Bild klicken)

2
Bazheeng

Es sieht aus wie eine unvollständige Konfiguration. Einige Dinge zu überprüfen:

  1. Stellen Sie sicher, dass PHP installiert ist und ordnungsgemäß ausgeführt wird. Versuchen Sie, php -v über eine Befehlszeile auszuführen und festzustellen, ob Versionsinformationen oder Fehler zurückgegeben werden.
  2. Stellen Sie sicher, dass das PHP -Modul in der httpd.conf Ihres Apache aufgeführt und unkommentiert ist. Dies sollte etwa LoadModule php5_module "php5Apache2_2.so" in der Datei sein. Suchen Sie nach LoadModule php und vergewissern Sie sich, dass am Anfang der Zeile kein Kommentar (;) steht.
  3. Stellen Sie sicher, dass die httpd.conf-Datei von Apache den MIME-Typ PHP definiert. Dies sollte so etwas wie AddType application/x-httpd-php .php sein. Suchen Sie nach AddType, und vergewissern Sie sich, dass ein Eintrag für PHP vorhanden ist (auch hier muss er nicht kommentiert sein).

Vielleicht könnten Sie versuchen, das PHP und PHP Modul für Apache erneut über die Befehlszeile zu installieren (ich weiß nicht, welche PHP-Version Sie verwenden, muss also möglicherweise angepasst werden):

Sudo apt-get install php5 libapache2-mod-php5 php5-mcrypt

Wenn Sie PHP7 haben, ändern Sie einfach PHP5 durch PHP 7.0, zum Beispiel:

Sudo apt-get install php7.0 php7.0-mysql libapache2-mod-php7.0 php7.0-mcrypt

Die Befehlszeile zum Aktivieren des Moduls PHP für Apache lautet:

Sudo a2enmod php5

oder

Sudo a2enmod php7.0

Sie können diesem Tutorial für die fehlenden Teile folgen: https://www.digitalocean.com/community/tutorials/how-to-install-linux-Apache-mysql-php-lamp-stack-on-ubuntu- 14-04

Ein Tutorial zur Installation von PHP7 und Ubuntu 16: https://www.howtoforge.com/tutorial/install-Apache-with-php-and-mysql-on-ubuntu-16-04-lamp/ =

2
Benjamin BALET

Ich bin spät dran, aber das wird irgendwann jemandem helfen. Ich hatte dieses Problem, nachdem ich mein Ubuntu aktualisiert hatte 16.04 auf 18.04 Dieser einzelne Befehl hat mein Problem behoben.

Sudo apt-get install libapache2-mod-php

libapache2-mod-ph ist ein Metapaket, das libapache2-mod-php7 installiert.

1
Akhilendra
Sudo apt install php libapache2-mod-php
Sudo apt install php7.0-mbstring
Sudo a2dismod mpm_event
Sudo a2enmod mpm_prefork
service Apache2 restart

nachdem

gedit /etc/Apache2/Apache2.conf

fügen Sie die folgende Zeile hinzu

Include /etc/phpmyadmin/Apache.conf

dienst Apache2 Neustart

0
Abhishek Kumar