it-swarm.com.de

Tote Tasten (Akzente) funktionierten nach dem Upgrade auf Ubuntu 16.04 nicht mehr

Tote Tasten für Akzente (wie â, è, ç) arbeiteten in LibreOffice und Pidgin nicht mehr, nachdem ich auf Ubuntu 16.04 aktualisiert hatte.

11
dsimard

Um das Problem zu beheben, habe ich ibus-setup in einem Terminal verwendet und die Anweisungen befolgt. Es ging wieder normal.

8
dsimard

Dieses Problem wird durch die nächste Eingabe besser gelöst:


$ ibus-daemon --xim


Außerdem aktivieren Sie diese Tastatureingabemethode in Systemeinstellungen - Sprachunterstützung:

Tastatureingabemethode system => XIM

Der Grund dafür ist, dass der "Ibus" immer dann Probleme verursacht, wenn eine Sprache komplexe Zeichen wie "à" enthält, selbst bei den "sehr bekannten" Nicht-Gnome-Anwendungen wie Skype und Microsoft Office-PlayOnLinux. Der typische Fehler ist, dass "` a "anstelle von" à "erscheint.

Meine Empfehlung ist, dass Sie den "ibus-daemon --xim" als Startup Application hinzufügen, um dieses Problem für immer zu vergessen.

2
some_user

Das von ibus-setup bereitgestellte Update funktioniert möglicherweise nach dem Start nicht. Fügen Sie zum Starten der Sitzung den Befehl ibus-daemon --xim hinzu, wie angegeben hier .


UPDATE AUF EINER ANDEREN URSACHE ALS iBUS:

In Kubuntu 18.04 hat alles geklappt. Ich habe versucht, LXQt darauf aufzubauen und keine toten Schlüssel in Libreoffice. Es scheint in diesem Fall kein ibus-Problem zu sein, sondern eines mit dem libreoffice UI-Backend - wie vorgeschlagen hier . Gelöst wie angegeben hier : editiere/erstelle die Datei /etc/profile.d/libreoffice-fresh.sh (oder /etc/profile.d/libreoffice-still.sh, wie gesagt hier ) und entkommentiere/füge die Zeile hinzu export SAL_USE_VCLPLUGIN=gtk3, dann neu starten.

1
user47206

Ich bekam dieses Problem, nachdem ich mein Debian-Testsystem mit dem XFCE-Desktop aktualisiert hatte. Ich habe es so gelöst:

  1. Klicken Sie auf XFCE -> Einstellungen -> IBus-Einstellungen
  2. Klicken Sie im Dialogfeld auf "Ja", um den IBus-Dämon zu starten
0
Thomas Rebele

Vor kurzem habe ich die Version von Unity auf Mate geändert und bin auf dasselbe Problem gestoßen. Ich habe eine Lösung gefunden, hoffe es hilft.

zentrales Bedienfeld -> ibus-Einstellungen -> Erweitert

deaktivieren Sie die Einstellungen für Tastaturlayout und globale Eingabemethode.

Bildbeschreibung hier eingeben

0
Bruno