it-swarm.com.de

Kali Linux Tools unter Ubuntu 15.04

Ich frage mich, ob ich die Kali-Hacking-Tools auf Ubuntu Vivid Vervet installieren könnte. Ich habe mehrere Anleitungen zur Installation am 14.04. - 14.10. Gesehen, aber keine am 15.04. Ich habe bereits versucht, die Debian-Repositorys zu installieren, von denen ich jetzt weiß, dass sie Ihre Distribution beschädigen. Bevor Sie Duplikate veröffentlichen, lesen Sie bitte, für welche Ubuntu-Version das PPA erstellt wurde, z. Utopisch, Raring usw. Ich brauche es für Vivid Vervet.

3
Mark Bourke

katoolin ist ein Skript, mit dessen Hilfe Kali Linux-Tools auf einer Linux-Distribution Ihrer Wahl installiert werden können. Diejenigen, die gerne die Penetrationstest-Tools des Kali Linux-Entwicklungsteams verwenden, können dies unter Ubuntu mithilfe von Katoolin effektiv tun. Die folgenden Anweisungen beziehen sich auf die Installation von Katoolin unter Ubuntu 15.04. Diese Anweisungen gelten auch für alle anderen derzeit unterstützten Versionen von Ubuntu.

  1. Öffnen Sie das Terminal und geben Sie Folgendes ein:

    Sudo apt-get install git  
    git clone https://github.com/LionSec/katoolin.git && Sudo cp katoolin/katoolin.py /usr/bin/katoolin  
    
  2. Mach /usr/bin/katoolin ausführbar.

    Sudo chmod +x  /usr/bin/katoolin  
    
  3. Führen Sie Katoolin wie folgt aus und Sie werden die Katoolin-Oberfläche sehen:

    cd /usr/bin/
    Sudo ./katoolin    
    

    enter image description here

    Wenn Sie zu Kategorien anzeigen gehen und dann 0 für alle eingeben, kehrt das Installationsprogramm sofort zu Ihrer ursprünglichen Position zurück. Scrollen Sie nach oben, und Sie sehen möglicherweise, dass einige der Pakete nicht gefunden werden können. Diese Pakete werden nicht mehr gepflegt oder wurden aus den Kali-Repositories entfernt. In diesem Fall ist es am besten, die Kali-Linux-Tools nacheinander in einer Reihe von Schritten zu installieren.

Warnung vor Updates nach der Installation von Kali Linux Tools

Die Webseite LionSec Katoolin GitHub warnt Katoolin-Benutzer eindeutig davor, beim Aktualisieren von Software vorsichtig zu sein.

Entfernen Sie vor dem Aktualisieren Ihres Systems alle Kali-Linux-Repositorys, um Probleme zu vermeiden.

enter image description here

Alle Arten von Problemen können auftreten, wenn Sie dies nicht tun.

4
karel

Ich bezweifle, dass Sie alle Kali-Werkzeuge finden werden. Es sind nicht nur die Werkzeuge, die Sie benötigen.

Kali ist eine eigens dafür gebaute Distribution. Die darin enthaltene Software wird für (beabsichtigte) Zwecke des ethischen Hackings und der Forensik ausgewählt. Der Kernel hat Modifikationen, die Software basiert auf Debian und die meisten, wenn nicht alle Pakete sind tatsächlich in irgendeiner Weise von Debian modifiziert.

Letztendlich werden Sie wahrscheinlich nicht alle Kali-Tools finden, aber vielleicht einige, wie Metasploit, aber Sie vermissen einige zweckgebundene sicherheitsrelevante Änderungen, die Kali zusätzlich zu Debian und Ubuntu vornimmt (dh, es stoppt Dienste) Laden beim Booten und andere Dinge).

2
Thomas Ward

Kali Linux verwendet keine PPAs wie die anderen Distributionen, dies ist Teil ihrer Sicherheit. Es ist jedoch möglich, Kali PPAs und Kali PPAs zu anderen Distributionen hinzuzufügen.

! ! ! ! ! ! AT IHR EIGENES RISIKO! ! ! ! ! ! ! ! ! ! !

WAGUNGS archive @ launchpad sie sind nicht offiziell, bitte gehen Sie zu kali.org

Bitte beziehen Sie alle Kali-Linux-PPAs aus der Tool-Liste auf der Kali-Site. Sie haben eine aktualisierte Liste von Tools mit Links und PPAs für all die Dinge auf ihrer Distribution. Nicht, dass Wagungs-Tools nicht sicher sind, aber dass man als Open Source-Benutzer Änderungen daran vornehmen kann, und ich werde Ihnen oder anderen Personen nicht sagen, dass sie Dinge besorgen sollen, die ich selbst nicht besorgen würde. Sie mögen sicher sein, aber ich rate Ihnen, Kali als offizielle Quelle für alle Einzelprojekte zu verwenden, um die Sicherheit Ihres Systems zu gewährleisten. Sie wissen also genau, wie Sie mit nicht manipuliertem Code umgehen.

! ! ! ! ! ! AT IHR EIGENES RISIKO! ! ! ! ! ! ! ! ! ! !

Wenn Sie möchten, dass die kali-Tools unter Ubuntu oder anderen Distributionen installiert werden, treten möglicherweise Probleme mit binären Abhängigkeiten auf. Eine Liste aller Kali-Linux-Tools auf ihrer Website finden Sie hier.

Liste der offiziellen Kali Linux-Websites

Sie haben alle PPAs und offiziellen Projekt-Links gut organisiert und auf dem neuesten Stand, wenn Sie mit den PPAs installieren möchten. Sie können also alle ihre Dokumentation auf Kali lesen, um ihre PPAs und Tonnen anderer netter Sachen zu installieren. Wie die meisten PPA-Datenbanken von Distributoren ist Kali's alles so versteckt, dass es am einfachsten ist, nur eine Festplatte für den Live-Boot zu haben, um alle PPAs abzurufen oder mit ihren Werkzeugen zu spielen.

Ich glaube, dass Kali und Ubuntu Probleme mit der Multi-Arching-Kompatibilität haben. Ich arbeite mit Trusty und es gab einige Probleme mit der Binärkompatibilität bei der Installation einiger Tools. Sie benötigen also Binärdateien, Quelldateien, Bibliotheken und PPAs, die nicht in Konflikt zueinander stehen, um eine erfolgreiche% 100-Mischung zu erzielen.

Kali ist leider so konzipiert, dass es keine PPAs verwendet, mit Ausnahme der Standardinstallation von zwei oder drei, die von Kali selbst bereitgestellt werden. Dies ist Teil ihrer strengen Sicherheitsfunktion, die ihre Distro so sicher macht, da es viel schwieriger ist, von Viren und Malware und dergleichen manipuliert zu werden.

Sie möchten sicherstellen, dass Sie nicht zu viele Kali-PPAs oder zu viele Ubuntu- oder Debian- oder Arch-PPAs jeglicher Art haben, da das Mischen von PPAs Sie in Ihr Grab ziehen kann. Sie kämpfen im Wesentlichen um Ihr System, wenn Sie mit Sudo apt-get upgrade verschiedene Pakete, Bibliotheken usw. installieren und entfernen. Dies kann zu Inkompatibilitätsproblemen und Konflikten führen, die über eine einfache Lösung hinausgehen. Sie können wirklich dazu führen, dass die Dinge flippig werden.

Es ist in Ordnung, Sudo apt-get mit den PPAs zu aktualisieren, aber nicht zu aktualisieren. Sie sollten die zusätzlichen PPAs für die Tools nach dem Update auskommentieren, um sicherzustellen, dass Sie Ihr System nicht durch ein Upgrade aus dem Gleichgewicht bringen. Die meisten Tools von Kali müssen per Quellcode installiert werden und PPAs müssen gemischt werden. Wenn Sie apt-get upgrade verwenden, können Sie die notwendigen Dinge löschen, damit Kali-Tools oder Ubuntu funktionieren.

Es ist sehr wichtig und ich muss betonen, dass Debian-PPAs (Kali's Deb based) nicht wirklich mit Ubuntu-PPAs auskommen. Obwohl jeder technisch auf Debian basiert. Sie sollten eher wie in Gesetzen gedacht werden. Dort ist Familie aber nicht wirklich erträglich aber man kann gut miteinander auskommen.

0
hansooloo