it-swarm.com.de

Österreichische Zielseiten funktionieren nicht wie erwartet

Abend alle,

Ich habe Probleme beim Einrichten einer Zielseite für österreichische Website-Besucher einer .com-Website mit mehreren installierten Sprachen (eine davon ist bereits deutsch und verwendet eine/de-URL).

Ich habe das Sprachpaket für Deutsch installiert, ich habe eine de- und eine at-Inhaltssprache eingerichtet und eine default-de- und eine at-Menüoption eingerichtet. Wenn ich zur .com/at-URL navigiere, behält sie immer die aktuelle Sprach-URL bei, fügt dann die at-Adresse wie .com/fr/at oder .com/de/at anstelle von .com/at hinzu und gibt mir dann einen offensichtlichen 404-Fehler .

Ich benutze Joomla! 3.4.8 und der Hauptsprachenmanager und Menümanager.

Irgendwelche Ideen?

Vielen Dank,

Andy

1
Andy Smith

Hallo @AndySmith und willkommen bei JSE.

Nach ihrer vierten Generation ist Joomla gerade reif genug, um solche seltsamen Fehler nicht alleine zu machen. Davon abgesehen bin ich mir fast sicher, dass eine Erweiterung dieses Problem verursacht: "Doppelsprachiger Code in URL mit SEF, der 404s ergibt".

In der Tat hatte ich vor ein paar Jahren ähnliche Probleme mit J2.5, die durch das 'Nice Ajax Poll Modul' verursacht wurden. Ich habe das im Joomla-Forum im Thema Doppelsprachiger Code in URL - SEF ergibt 404 geteilt, und es stellte sich heraus, dass es andere Erweiterungen gab, die für ähnliche Probleme verantwortlich waren (ChronoForms, Extrawatch, etc ...). Ich weiß, ich sollte einen Auszug aus diesem Beitrag auflisten, falls der Link ausfällt, aber in diesem Fall ist das einfach nicht möglich.

Ich habe offensichtlich keine genaue Antwort auf Ihr Problem. Ich öffne nur die Augen für die Möglichkeit, dass eine Erweiterung (entweder eine Komponente, ein Modul oder ein Plugin) dies verursacht hat. Sie müssen es testen, indem Sie sie einzeln deaktivieren. Viel Glück.

1
Mikan