it-swarm.com.de

Komponente von 2.5 auf 3.3 migrieren

Diese Dokumentation: Anpassung einer Joomla 1.5-Erweiterung an Joomla 2.5

http://docs.joomla.org/Adapting_a_Joomla_1.5_extension_to_Joomla_1.6#Renamed_events

Hat mir sehr geholfen, als ich meine Komponente auf 2.5 migriert habe.

Ich frage mich, ob es etwas Ähnliches gibt, das Ihnen zeigt, wie Sie Ihre Komponente von 2.5 auf 3.3 migrieren können

Vielen Dank

5
Piero Marsilio

Selbst der Link, den Sie in Ihrer Frage angegeben haben, enthält nicht alles, was bei der Migration einer Erweiterung geändert werden muss. Es gibt immer ziemlich große API-Unterschiede zwischen jeder Long Term Release-Version von Joomla.

Für Joomla 3.x sehe ich mir hauptsächlich Folgendes an:

Mögliche Probleme mit der Abwärtskompatibilität in Joomla

Außerdem schaue ich mir die neueste API-Site an:

http://api.joomla.org/cms-3/

Hoffe das hilft

12
Lodder

Wenn Sie nur versuchen, es zum Laufen zu bringen, helfen die bereitgestellten Links @Lodder massiv beim Umgang mit veraltetem Code. Während der Arbeit an 2.5.5 wurde eine Reihe von 3.x-Code zurückportiert. Wenn Sie also nur diese Version oder eine neuere Version unterstützen, können Sie theoretisch eine Komponente relativ einfach sowohl für 2.5- als auch für 3.x-Versionen verwenden. Was nicht dokumentiert ist, sind die Layoutänderungen, die mit dem Wechsel zu Bootstrap einhergingen. Sie müssen die Kernkomponenten als Modell dafür verwenden.

Wenn Sie Unterstützung für 3.x-Funktionen (z. B. Tags oder Inhaltsverlauf) hinzufügen möchten, müssen Sie weitere Arbeiten ausführen. Mithilfe dieser Links können Sie die Unterstützung für diese Funktionen integrieren:

4
Michael

Komponente von 2.x nach 3.x migrieren

verweisen Sie auf diesen Link,

schritt 1: Differenz zwischen 2.x in 3.x

schritt 2: Wichtige Methoden

2
kumarramalingam