it-swarm.com.de

Können Sie SICHER von 3.4.x oder 3.5.x auf 3.6.2 aktualisieren?

Vorausgesetzt der "Tanz", der für das Joomla 3.6.1-Upgrade erforderlich ist , ist es möglich, direkt von 3.x mit X <auf das 3.6.2-Release zu aktualisieren 6? (Also Versionen 3.4.x oder 3.5.x…)

Oder sind zusätzliche Schritte erforderlich? (Die Version 3.6.2 macht es nicht klar.)

1
Craig

Die Version v3.6.2 ist nicht viel besser als die Version v3.6.1, was das Joomla-Update betrifft (es sei denn, Sie aktualisieren Websites noch auf PHP 5.3).

Der Hinweis unter https://www.joomla.org/announcements/release-news/5666-the-joomla-3-6-1-update.html gilt nach wie vor ziemlich genau für Version 3.6.2.

Ich habe heute ungefähr 20 Sites aktualisiert, hauptsächlich von Version 3.5.1, und dies ist das Beste, was ich tun konnte:

  1. führen Sie eine Sicherung durch und kopieren Sie die Sicherungsdatei außerhalb des Standorts

  2. aktualisieren Sie Erweiterungen von Drittanbietern zuerst auf die neuesten Versionen

  3. deaktivieren Sie vorübergehend das Plugin "System - Backup bei Update", wenn Sie Akeeba Backup installiert haben (dieser Schritt ist wahrscheinlich nicht mehr erforderlich, wenn Sie zuerst auf Akeeba Backup v5.1.4 aktualisieren).

  4. führen Sie das Joomla v3.6.0-Update aus, das in der Joomla Update-Komponente angeboten wird

  5. klicken Sie auf die Schaltfläche "Cache löschen"

  6. führen Sie das Joomla v3.6.2-Update aus, das in der Joomla Update-Komponente angeboten wird

  7. navigieren Sie bei dem Fehler "Ungültiges Sicherheitstoken" zurück zu /administrator dann geh zu Extensions -> Manage -> Database und klicken Sie auf die Schaltfläche "Fix"

  8. aktivieren Sie das Plugin "System - Backup on Update" erneut

  9. gehen Sie zu Erweiterungen -> Verwalten -> Aktualisieren und aktualisieren Sie das "Joomla Update" -Plugin auf die neueste Version (möglicherweise müssen Sie auf "Cache leeren" und "Updates suchen" klicken, bevor das Update angeboten wird).

1
Neil Robertson

Aufgrund des Debuggens eines SQL-Problems habe ich gerade meine Testserver-Installation von 3.5 aktualisiert. auf 3.6.2 über die Schaltfläche Aktualisieren. Ich hatte überhaupt keine Probleme, selbst mit all den halbfertigen Komponenten und Modulen, die ich bereits auf der Testsite und in der entsprechenden Datenbank installiert hatte. Ich hätte nicht gewusst, dass es Probleme mit früheren Versionen gab, bis ich Ihre Frage sah. Das Update war reibungslos und schmerzfrei und alle meine eigenen Erweiterungen funktionieren wie vorgesehen.

Natürlich hängt Ihre eigene Erfahrung von den von Ihnen installierten Erweiterungen ab, und ich würde sicherstellen, dass Sie diese zuerst auf einem Entwicklungsserver testen, aber Joomla selbst scheint in Ordnung zu sein, sie zu aktualisieren.

1
chrBrd

Ich verwalte meine Websites mit Watchful.li. Ich gebe gerne Requisiten, wenn etwas einfach funktioniert. Ich habe heute buchstäblich 50 Sites auf Joomla 3.6.2 aktualisiert, ohne dass Probleme aufgetreten sind (abgesehen von 2 nicht zusammenhängenden Erweiterungsproblemen). https://watchful.li/

0
YellowWebMonkey