it-swarm.com.de

Was ist die maximale Version von PHP, die Joomla 1.5 ausführen wird?

Ich habe einen Client mit einem alten Joomla 1.5, den sie dieses Jahr nicht aktualisieren möchten, aber ihr Host möchte den Server aktualisieren. Was ist die maximale Version von PHP, die Joomla 1.5 ausführt, anstatt der angegebenen min?

http://www.joomla.org/technical-requirements.html#footnote-1xPHP
Joomla! versions 1.5.15 and later are compatible with PHP 5.3.

Würde es am 5.3.10 gut laufen? Ich würde vermuten, dass es bei 5.4 kaputt gehen würde, aber ich finde es schwierig, eine Testmaschine mit alten Versionen zum Testen zu bauen. Also mehr Frage aus Erfahrung.

vielen Dank

4
tristanbailey

Wenn Sie Joomla 1.5.14 oder unter ausführen, sollten Sie sich an PHP 5.2 halten, da es möglicherweise einige Funktionen und gibt/oder Code-Schnipsel, die unter PHP möglicherweise nicht funktionieren. 5.3

Wenn Sie jedoch Joomla 1.5.15 oder über ausführen, können Sie problemlos auf PHP 5.3 aktualisieren. Wenn Sie die OpenID-Bibliothek verwenden, ist diese nicht mit PHP 5.3 kompatibel. Daher müssen Sie entweder eine Alternative finden oder bei PHP 5.2 bleiben

Weitere Informationen zu den Versionen von PHP, MySQL und Apache finden Sie unter Technische Voraussetzungen

Ich würde vorschlagen, dass Sie auf Joomla 1.5.26 upgraden, die neueste Version der 1.5-Serie.

Hoffe das hilft

5
Lodder

Ich führe eine Joomla 1.5.26-Site neben einer neuen J3-Site aus, die sich auf derselben PHP -Installation im Aufbau befindet. Die J1.5-Site läuft unter PHP 5.6 einwandfrei, ohne dass irgendwelche Änderungen vorgenommen wurden. Die J1.5-Site ist eine sehr einfache Site mit nur wenigen Erweiterungen.

4
biltong

Ich bestätige, dass Joomla 1.5.24 auf PHP= 5.5.9-1ubuntu4.17. PHP-FPM wurde mit apt installiert. Webserver ist Nginx. Alle Funktionen scheinen reibungslos zu laufen.

3
Egeshi