it-swarm.com.de

So konfigurieren Sie Glassfish Server manuell in Eclipse

Ich habe GlassFish Server3.1.2.2 auf meinem Rechner installiert. Was ich in meiner Eclipse Luna verwenden möchte

Wie konfiguriere ich es manuell für die Verwendung in Eclipse?

Bei der Verwendung von Eclipse Market Place habe ich eine Fehlermeldung erhalten Kein Repository unter http://download.Oracle.com/otn_software/oepe/luna gefunden.

Ich habe versucht, durch das Netz zu suchen, für das ich auf das Oracle Enterprise Pack für Eclipse (OEPE) hingewiesen werde, das etwa 485 MB beträgt.
Gibt es einen anderen Weg dafür?

28
InCh

Sie müssen Eclipse WTP (Web Tool Platform) verwenden. Die letzte Version ist Luna 4.4. Link-Download: Eclipse IDE für Java EE-Entwickler http://www.Eclipse.org/downloads/packages/Eclipse-ide-Java-ee-developers/lunar

Menü Windows\Show view\Other, wählen Sie den Ordner Server und klicken Sie auf Servers.

enter image description here

enter image description here

Klicken Sie mit der rechten Maustaste auf den leeren Bereich, um das Kontextmenü zu verwenden, und wählen Sie New\Server.

enter image description here

Presslink "Zusätzliche Serveradapter herunterladen"

enter image description here

Wählen Sie "GlassFish Tools" vom Oracle-Anbieter. 

enter image description here

Starten Sie Eclipse anschließend neu.

36
foobarfuu

Ich könnte es mithilfe der folgenden Schritte beheben: (GlassFish Server3.1.2.2 und Eclipse Luna 4.4.1)

  1. Hilfe> Eclipse Marketplace> GlassFish suchen> Sie sehen GlassFish-Tools> Wählen Sie das entsprechende Produkt aus und installieren Sie es.
  2. Starten Sie Eclipse neu
  3. Windows> Öffnen Sie Ansichten> Andere> Server> Server> GlassFish 3.1
  4. Sie müssen jdk1.7.0 zu Installed JRE hinzufügen. Schließen Sie das vorherige Fenster, um den neuen Standard jdk1.7.0 zu übernehmen.
21
user4530877

Diese Frage scheint etwas veraltet zu sein, aber hier ist meine Lösung.

Ich gehe davon aus, dass Sie GlassFish bereits auf Ihre Festplatte heruntergeladen und die Dateien in einem Verzeichnis entpackt haben.

A - Eclipse MarketPlace/Installieren von GlassFish-Tools

Wie in früheren Antworten bereits erwähnt, müssen Sie GlassFish Tools von Eclipse marketplace herunterladen.

Hilfe -> EclipseMarket Place

 enter image description here

Installieren Sie GlassFish unten auf dem Bildschirm.

 enter image description here

B - GlassFish Server hinzufügen

Öffnen Sie die Serveransicht, wenn sie unten in Eclipse nicht sichtbar ist.

Fenster -> Ansicht anzeigen -> Server

 enter image description here

Wenn die Serveransicht sichtbar ist, klicken Sie einfach auf "Es sind keine Server verfügbar. Klicken Sie auf diesen Link, um einen neuen Server zu erstellen ..." (siehe unten).

 enter image description here

C - GlassFish Server hinzufügen

Wählen Sie im Fenster Neuer Server wie unten gezeigt GlassFish aus. Nach meiner Erfahrung gibt es nur eine GlassFish-Option, die ich anstelle von mehreren GlassFish-Optionen mit Versionen auswählen kann, wie unten gezeigt;

 enter image description here

D - Konfigurieren von GlassFish- und Java-Speicherorten

Geben Sie den genauen GlassFish-Speicherort sowie den Java-Speicherort ein (siehe unten).

 enter image description here

E - Letzter Schritt

Lassen Sie im letzten Schritt dieser Konfiguration einfach alles so wie es ist. Der Einfachheit halber definiere ich kein Admin-Passwort.

 enter image description here

Jetzt ist alles eingestellt, hoffe das hilft!

13

Um Glassfish-Tools mit Eclipse Luna verwenden zu können, benötigen Sie Java 8 . Ich hatte auch dieses Problem, weil ich Java 7 hatte. Wenn Sie Java 7 in Ihrer Umgebung haben, laden Sie Eclipse Kepler herunter. Es wird gut funktionieren.

8
Tulip Agarwal

Ich hatte das gleiche Problem .. Ich konnte weder mit Marketplace noch mit Servers tab installieren.

Folgendes ist die Alternative.

1) Hilfe -> Neue Software installieren
2) Verwenden Sie die URL: http://download.Oracle.com/otn_software/oepe/12.1.3.6/luna/repository Oben ist das OEPE-Tool von Oracle für die EE-Entwicklung.
3) Wählen Sie aus allen Vorschlägen Glasfischwerkzeuge aus.
4) Installieren Sie es . 5) Starten Sie Eclipse neu. 

Eclipse 4.4.2 Luna JDK: 1.8 

3
Harshit

Ich hatte das gleiche Problem, um das Problem zu beheben, gehen Sie zu windows -> preferences -> servers und wählen Sie die Laufzeitumgebung aus. Nun sehen Sie ein neues Fenster. Rechts oben sehen Sie eine Option. Klicken Sie auf und installieren Sie den Glassfish-Server. 

1
alvaro7710

Für Eclipse Mars verwenden Sie den ähnlichen Ansatz als Harshit.

1) Hilfe -> Neue Software installieren
2) Verwenden Sie url: http://download.Oracle.com/otn_software/oepe/mars repository. Oben steht das von Oracle für die Entwicklung von EE bereitgestellte OEPE-Tool.
3) Wählen Sie unter allen Vorschlägen Glassfish Tools (Oracle Weblogic Server Tools, Oracle Weblogic Scripting Tools, Oracle-Patches, Oracle Maven Tools) aus.
4) Installieren Sie es.
5) Starten Sie Eclipse neu

In Punkt 3) sind 4 Werkzeuge in geschweiften Klammern, ich weiß nicht, welche Kombination minimal ist, aber die Installation von Glassfish Tools hat keine Auswirkung.

Während des Neustarts fragt Oepe nach Java 8 JDK, ob Eclipse auf einer älteren Version ausgeführt wird.

Eclipse 4.5.0 Mars JDK: 1.8

1
hariprasad

Für Eclipse Luna

Gehen Sie zu "Hilfe"> "Eclipse MarketPlace"> "GlassFish-Tools suchen" und installieren Sie es.

Starten Sie Eclipse neu.

Gehen Sie nun zu Server> Neu> Server und Sie finden den Glassfish-Server.

1
Suketu