it-swarm.com.de

Laden Sie JavaFX für Eclipse herunter und installieren Sie es

Ich bin ein erfahrener Entwickler (Java, Eclipse & Maven) und habe bisher ein paar Frameworks verwendet. Jedes Mal, wenn ich versuche, mit etwas Neuem zu beginnen, scheint es, dass ungefähr eine Zillion-Konfiguration zum Herunterladen und Installieren vorhanden ist.

Ich habe hier nach Anweisungen und allen nahen Seiten gesucht, aber sie scheinen veraltet zu sein, der Eclipse-Plugin-Pfad ist ungültig, und wenn ich die neueste Version installiere, habe ich keine Seite gefunden (2.0.2). , besagt, dass ich eine neuere Version installiert habe.

Auch scheint das Maven-Setup in den meisten Beiträgen, die ich gelesen habe, unklar zu sein.

Ich benutze:

  • Windows 7
  • Eclipse x64 Indigo
  • JDK x64 1.6.0.24
  • Maven 3.0.3 

Und ich erinnere mich nicht daran, JavaFX installiert zu haben.

Was fehlt mir? Wo kann ich etwas über das Setup erfahren, um mit diesem Framework arbeiten zu können?

10
TacB0sS

JavaFX wird installiert, wenn Sie das neueste JDK 7 von Oracle installieren (im Lieferumfang enthalten).

Das Eclipse-Plugin finden Sie hier: 

http://efxclipse.org/

Wenn Sie an Maven-Builds interessiert sind: Ich habe kürzlich eine erste Version von Drombler FX veröffentlicht, einem modularen RCP für JavaFX, das auf OSGi und Maven (POM-first) basiert:

http://puces-blog.blogspot.ch/2012/12/drombler-fx-building-modular-javafx.html

http://wiki.drombler.org/GettingStarted

14
Puce

Ich habe es mit efxclipse versucht, aber es reichte mir nicht. Ich habe auch versucht, den Pfad der javafx-JAR-Datei an efxclipse zu übergeben. 

Window-> Prefrences-> javafx -> "Der Pfad zu javafx jar..... Jfxrt.jar"

. Aber nichts hat funktioniert für mich weiß ich nicht, was schief lief. 

Dann füge ich einfach die jfxrt.jar -Datei meiner Bibliothek hinzu und alles hat gut funktioniert: - 

 1. Right click your JRE System Library
 2. Build Path
 3. Configure Build Path
 4. Add External Jars
 5. "The path to jfxrt.jar"

Sie können jfxrt.jar -Datei von this link herunterladen.

Oder

Wenn Sie bereits das neueste Oracle Java JDK heruntergeladen haben, finden Sie diesen Pfad 

Extracted_Oracle_jdk_folder/jre/lib/ext/jfxrt.jar

Es sollte alles gut funktionieren.

0
chandan sr

Probieren Sie e (fx) clipse unter http://efxclipse.org/ aus. Ich bin ein Entwickler von Netbeans, habe aber von meinem Eclipse mit Freunden eine Menge guter Dinge über dieses Plugin gehört.

0
Lakatos Gyula